WD My Book 4Tb attached to ASUS RT-AC68u to backup My Cloud NAS (Safepoint) and PC (Smartware)

I have a WD My Book 4Tb USB-attached to a ASUS RT-AC68u 

I also have a WD My Cloud NAS.

WD backup ecosystem uses " WD Smartware Pro" to backup Windows PC to WD attached disks and NAS. On a WD NAS, it also uses a function called " Safepoint" to automatically backup the whole NAS somewhere else (in order to recover if there is a failure with the NAS).

First, from the My Cloud NAS (will call it NAS ), I tried to setup a Safepoint on the My Book attached to the ASUS RT-AC68u (will call it MBasus ). The MBasus see the share on the NAS and ask for the ID and password to access the share. Whatever I try, I’m said that either the id or the pw is invalid, and as far as I know, it is really not the case. Is there something I should do to make them “friends”?

Second, from my PC (Windows 8.1), I tried to setup a PC backup using " Smartware Pro". In its setup page, Smartware doesn’t even see (or show) the MBasus drive. Again, is there something I should know and do in order to have Smartware be aware of the drive attached to the Asus router?

Thanks for helping.



Make sure that you are following the steps correctly to setup the safepoint.

For troubleshooting steps, are you able to create a new share on the my book without password protection.

Please see the link below


Regarding the Backup on the computer, the WD Smartware wont be able to see that My Book on the Asus router.