WD My Book 3To. Not recognized on USB 2.0 ports

Hi everyone,

Recently I have got a weird problem with My Book 3To. It is not recognized on USB 2.0 ports but is on USB 3.0. But in the first months after buying it I worked with it on a computer with only USB 2.0 ports…

Anyone have an idea of what is going on and what can I do to solve it? (I have tested that on another PC with a USB 3.0 port, only on this port the HDD is recognized…) 


MIne is having same problem. Worked fine for past 2 months, quit yesterday.  What’s the fix?

Try updating the drivers for the USB 2.0 controller.

Do you have a different cable you could try?

Yes I have, I tried with the cables from two other WD external drives I have. The problem still persists.  I’ll try to update the USB drivers, but last time I tried they were up to date.

Sometimes it will make a difference if you uninstall the drivers first. You can do it through Device Manager, on the Driver tab. It will probably ask if you want to delete the files as well, which I would do since you’re trying to fix something.

Of course, you want to be able to reinstall the driver. This can frequently be done through Windows Update, if you allow it, or you can seek out the manufacturer’s drivers directly if there’s anything special about your setup. USB 2 drivers most likely can be gotten from Windows Update, though. It’s USB 3 that can be more finicky. It’s unusual that you have 3 working but not 2.

UPDATE: A friend just turned me on to this guide for cleaning up USB driver clutter.


I think this is well worth trying.

I will try that, but it seems that this issue is not driver related. What tickles me is that the drive is detected on other computers with the USB 3 port (and not USB 2), so this seems like an issue regarding USB 2 with the hard drive and not the computers where I plug the HDD in.