WD My Book 2TB not working

I have one of the older WD My Book 2TB with the Blue circles at the front.  (WD200000D033-001)

It was working fine until I left it on for about 4 or 5 days and now it’s not working.  

When I plug AC power into the back, the blue circles flash briefly at the front, then the initializing sound occurs and I can hear the HDD’s start up and it sounds like a fan is running but I can’t see the drive through mionet or ping the device with the IP it had before.  Can’t see it in my ARP table on my router either.

I’ve tried soft and hard resets but neither have helped or appeared to have worked.  about the only thing I haven’t tried is plugging it in via USB but I can’t find the USB cable (appears to be an A to A connection) and it normally ran fine over ethernet (very slow though as it’s 10/100).

Can anyone else help with further suggestions?  Has it overheated and should I leave it for a few days or put it in the freezer?


The drive will not work trough USB. If the drive is not longer been recognized it could be that the drive failed.

Make sure you properly reseted the unit, try this steps: 

Reset My Book World

You can also try a different ethernet cord.