WD media player not recognising segate 3TB hard rive

 prior to my WD media player completely not recognizing my media player i have had minor problems… i would often have to restart the device through the menu in order to get the player to recognize the hardrive. However today I was unable to get the player to recognize the hardrive despite my usual fix it method. It also appears to have no network connection and i am unable to click on the RSS icon, resulting in no wifi connection. I have tried resetting the device but still no changes in all previously mentioned problems. I am running my hardrive on a mac pro and it works fine. It is only with WD player that it is unrecognized… 

pls help!

Which WD media player?

If the HD is formated with HFS+, I am pretty sure WD doesn’t support HFS+ partitions larger than 2TB.

I had the same problem and reformatted the 3TB drive to FAT32. The entire disk works with WDTV. The maximum possible size for a file on an FAT32 volume is 4 GB minus 1 byte.