WD MBL keeps initializing after failed firmware update

I performed a firmware update from the dashboard after being informed by email. The update ran and was 90% complte when it ran into and error. Did not make a note of the code, sorry. I retried right afterwards. That one went sooner, but also came to an error. Both errors were caused by a network problem, but there is nothing wrong with my network or the internet access.

After that  I went to the Support page and hit the blue button in the lower left column for saving a network problem report. It started up, but now it shows ‘Initializing device, please wait’. The picture of the drive in the lower left corner now radiates in yellow. Should be green if I remember well. That message if there for more than an hour now.

I can access the data on the NAS from explorer, but even if I leave the dashboard, when I come back the situation has not changed and the drive is still ‘initializing’.

Well…, I gave it another try. Ignoring the initializing message. Just ran the update again for the 3rd time. It worked out. Everything OK now.


So you had to run the update for a 3rd time in order to make it work properly?

I just bought this MyBook Live 2TB and have the same thing. I went to the UI, wanted to update, it failed. Downloaded the update again and it got stuck at 100% download.

I waited for an hour and pulled the plug. Rebooted and now it keeps saying ‘initializing device, please wait…’

Problem is, no matter how fast I click the UI I can click ‘settings’ but after that the popup is there with the ‘initializinf device blablabla’ and I can no longer click anything behind it, hence am not able to try and update again.

I think the initializing message is bogus but cant get around it.

Kinda **bleep** for a first impression… Anyone got an idea? Is there an update file to update without using the UI ?

Can you enable SSH real quick by changing the end of the url in the browser address bar to /UI/ssh and then quickly ticking the SSH box?

yes, that seemed to work, the box stays ticked. Now what ? :slight_smile:

Follow this guide



Let me know if it clears up your initializing error and tell me what firmware you are on now and I will send you a PM with a link to the latest firmware.

You need to be on at least 02.11.09-053 to upgrade to the newest firmware

It worked! Had to use http://community.wd.com/t5/My-Book-Live/GUIDE-Restore-Downgrade-firmware-via-the-reset-button/td-p/481588 option 3 to get there, I think mainly because only there I discovered there was a version 2 of the resetActionButton.sh file. Nonetheless I executed it by hand just to make sure…

It acts ‘normal’ again, is now in its 2nd attempt to upgrade normally to the latest firmware (1st attempt got stuck at 90% :S).

But at least if it gets stuck I know what to do now :slight_smile:

Thanks alot !

Edit: didn’t see the remark about the latest FW… If you have it on file then please PM me… I think it’s stuck again…

Sure thing

PM sent

The link is not available… When I click on it I get an error (not enough privilege?).

Is this restore/downgrade firmware procedure available elsewhere?

I had to remove the guide, sorry :frowning:

Try holding the reset button on the back of your drive in for 6-8 seconds and see if that fixes you up when the drive reboots