WD MBL 3TB connection issues

I’m hoping someone may be able to help - I’ve tried searching, but i’ve been unable to find a sollution.

Today, I’ve moved my MBL downstairs so it’s connected directly into the modem so now I can access it externally with no issues what so ever.

However, I have 2 networks - The modem is running on I have a router which is connected into the modem which runs on

Now that i’ve moved the MBL and connected it onto the network, I can still access the MBL from my computer through the internal IP address, but now when I go to connect to the MBL on my XBOX or WD TV Live box through Windows Shares, it’s no longer able to find the MBL.

Does anyone out there have any sollutions or ideas? :-S 

The WDTV requires that the servers be on the same network.  Not sure how the XBOX behaves; never had one.

So, in short, that’s not going to work for you since your MBL is on a different subnet than your WDTVs.

Why do you have two internal networks?   Perhaps you don’t need that?

The 2 networks is in place just purely because of my Sky Modem - If I try to merge the pair, the Sky Modem has a fit of giggles and bricks.

The reason I’ve connected the MBL to the Sky Modem is to remove complications I had when I had it connected to my internal network… I ran through firewall issues, I setup the firewall rules on the Sky modem too - But I still couldn’t access it from outside my house.

But now I’ve connected it to the sky modem, I can’t access it in the house! lol… Oh it’s a headache on a stinking hot day.

Just thinking - Maybe if I disable the Sky modem’s firewall completely and just turn it into a modem, then connect the MBL to the router again and setup the firewall rules- Surely this would mean it should run both indoors and out, as the Sky modem will no longer be able to intervene with what the routers firewall is allowing and blocking?

I’m not sure if I’m over thinking this and can’t see what’s basically obvious but it’s definitely annoying lol.