WD MBL 2TB running less than 120 KB/s through Gigabit Ethernet connection


The My Book Live is connected by Ethernet to a D-Link DIR-860L Wireless AC1200 Dual Band Gigabit Cloud Router, which is connected to my laptop’s gigabit-capable Ethernet plug.

The transfer rate (taken from Windows Task Manager under Bytes per Interval and refresh on Normal, i.e. 1 sec/interval) varied widely from 100KB/s - 20KB/s and averaged around 40-50KB/s.

I know this is not usual because I regularly get 25-30 Mb/s (our paid limit) on both the Ethernet and wireless individually AND my laptop is connected to the router through a bridged 5.0GHz N wireless and Gigabit Ethernet connection setup.

This slow performance is with No other computers taxing the router or accessing the My Book Live and with my laptop not being taxed by other programs.  Also, this performance is comparable through the WD SmartWare AND SyncToy 2.1 64-bit (from Microsoft).  I just stopped a backup of about 90GB, and it didn’t even get halfway through after 2 FULL Days of running leaving it running all night.

Please Help.  I don’t feel like waiting 10+ days at the current rate.  :confounded:

P.S.  The backup attempted above is only 1/3 of the amount needed to be backed up from this laptop, and there are more family laptops. :neutral_face:

UPDATE: I recently called WD Support and they had me use a pen to reset the My Book Live (As if that’s supposed to solve anything).  The speed for ONLY standard drag-and-drop or copy/paste transferring increased to 20-30Mb/s (for large files, tiny files still slow).  Also, WD SmartWare is STILL operating at a MAX of 400-500 KB/s (~3-4Mb/s), and Microsoft’s SyncToy 2.1 64-bit is STILL at a MAX of 40-70KB/s (~320-560Kb/s). WHY!?!? :confounded:

Used cmd.exe for “net use” command and confirmed the WebDAV issue has nothing to do with this.  Temporarily turned-off Windows Firewall, No Change (Same result with anti-virus).

I can’t find ANYTHING wrong other than bad programming on WD’s part on the MBL itself, Not SmartWare.  WHERE are the WD forum moderators?

As a result of the before mentioned problems, I have spread numerous 1-star reviews on this product.  I am strongly considering returning this drive from where I got it.  Very DIS-satisfied.

I’d be checking your LAN hardware / cabling for issues.

If you’re using WiFi, that’s a whole 'nother story.

30 Mbits / second is about 1/10th of what I normally get.   I get 20x that with read speeds.  

It’s not “bad programming” or many more people would have the issue.   I have 4 MBLs on my network right now, and have no speed issues with any of them.

If it wasn’t “bad programming” as I said, then why is SmartWare Itself 1/10th of the copy/paste speed?  I understand that even the copy/paste & read speeds should be faster than what I posted, but why would a file-managing program be so bogged-down?  It reminds me of someone over-thinking a task so much that it doesn’t get done at all.

Here’s how I’m reading this situation:

The copy/paste is 30Mb/s & should be faster, but don’t know what the limiting factor is (most likely settings, not hardware); SmartWare is 1/10th the copy paste speed, so there must be some “overthinking” or software setting that’s inadvertently capping the transfer rate; however, since Microsoft’s SyncToy is comparable to SmartWare in speed, whatever is capping the Automated Program speed must be somewhere in the MBL’s settings itself and it must only affect automated programs.

I’ve been through all the settings multiple times and can’t find anything that would affect program copying but not direct copying.

Smartware isn’t just copying files.  So, yeah, it’s thinking a lot – it’s encrypting, compressing, calculating checksums, and aggregating them into bundles.

I haven’t used Synctoy in ages (I now use FreeFile Sync), and don’t see any speed issues.   Don’t remember any with Synctoy when I was using it, either…

By the way, some current settings are:

There’s one user with password & the shares have media streaming disabled (unused) & are passworded too.

System: Firmware Auto Update Enabled, Hard Disk Sleep Enabled, Mac Backups Disabled (unused)

Network: Mode is Static (due to connectivity issues on DHCP) & FTP Allowed (on/off = no transfer rate change)

Remote Access: Enabled & Automatic, No Mobile devices or Web accounts entered

Media: Twonky & iTunes are Disabled (both unused)

Everything else seems irrelevant to this issue.

I just finished a backup with SmartWare that took between 4-5 continuous days/nights and I’m running SyncToy to continue diagnosing transfer rate issues.  I’m continuing on with router settings at the moment, since the MBL settings “seem” to be practically clean regarding bandwidth.

In your SyncToy profile settings, you don’t happen to have the “Check File Contents” option enabled, do you?


I just checked and that option is indeed off, & I have Exclude system files checked as your pic shows but I left Exclude hidden files unchecked.

I’m starting to think all this slugishness might be from the D-Link DIR-860L router settings, but I haven’t found anything to prove it yet.


I received a call from WD staff today and some questions were answered (and apparently fixed by reinstalling SmartWare and testing the MBL through direct ethernet to my laptop … no router).  However, even though direct copy/paste transfers are now quite fast, it seems that I must give up all hope of fast transfers using any variety of automated backup programs (WD’s SmartWare and Microsoft’s SyncToy for example).

Direct copy/paste transfers are now up to ~28 MB/s (~224 Mb/s).  However, any form of automated program involvement seems to be capped at 200-300 KB/s and (interestingly enough) any direct copy/paste operations run During an automated program transfer still run at nearly full speed (minus the 200-300 KB/s from the automated program).  The issue must be something with a firewall, router settings, etc.

Soooo, I suppose its “solved” from a WD Community standpoint, but I still have some tweaking to do.  :wink: