WD LV tive gen3 MKV 720p and 1080p frame stutter


Ok so I’m getting frame stuttering mainly on panning video, this happens all the way through the movies.

It’s happening on a variety of .mkv files from 720p through to 1080p, they are playing fine on 3 pcs.

I’m using the 1.05.xx firmware and will update to the 1.06 if this fixes the problem, does anyone have any ideas as it’s driving my crazy lol.

Are you streaming wireless or with a  wired connection. Unfortunately with media with a high bitrate it appears wireless can not keep up with the data. 

I just bought the wd live streaming player… It has updated the content metadata and is up and running. I had the same issue of stuttering video for HD Video. The image doesn’t keep up with the audio and you see it stuttering. It has happened in avi format so far. This is the second wd live streaming player that i’ve tried it on and it doesn’t work even though the video works fine on my laptop.

PS: it’s an actual file and not being streamed online… it’s pulling it from my usb drive connected directly to the player.

have you tried both usb ports?

Hmm, should work perfectly with the local USB storage. Try downloading BitRate Viewer and test to see what the bitrate of the movie is.


I am playing via usb, files range from 4gb to 11gb and are all .mkv that have issues.

They work fine on 3 pcs / laptops and a friends media player.

I’m having the same problem. It appears to have started since I did the last upgrade. I am using a WD drive. The skipping/stuttering only happens with MKV containers w/ x264 encoding. All files play without problems on my laptop. I will downgrade to the older firmware and see what happens.

I did a hard reset to factory firmware, it helped slightly but it’s still a evident problem

I don’t know what wd are doing to investigate, it annoys me particulary because the gen2 works fine, so how hard can it be to fix?

Looking at getting a popcorn hour media player now, interface may not be as good but atleast it will play without having too many issues.

I rolled back late last night  to 1.04x and watched an MKV that had previously stuttered. I didn’t have time this AM to watch the entire video but it was playing without problems. My guess is there is a codec conflict happening. Something similar happened on my computer when there was a generic divx codec trying to play a file it didn’t jibe with. After I added a codec to the library I no longer had the problem.

cool, ill give it a try. where can i find the 1.04 firmware?