WD looses my USB Drive

I have tried several WD TV Live divices and all work great with my USB drives for about a week and then it starts to get very slow moving from folder to folder and frequestntly tells me that "my content source has been removed " and it needs to reboot the drive before before I can find my files.  I have tried a WD drive as well as a Seagate 2.0 as well as 3.0 and returned by device for another one…Same issues.  I have the latest firmware.  Plesae help.

Have you tried doing a factory restore and a Hard reset on the media player?

I have the same or similar problem, read my message stream to review. I am currently working through a second factory reset and load up latest firmware 1:12:14 and now am testing once more to see if the usb drive randomly disconnects again from the WD Live. It’s  a very frustrating problem. Until I can confirm the factory reset (twice applied) has worked I don’t have any answers yet.  

Suggest you read the comments stream in the extrenal drive section of this WD community to see what has been tried and suggested so far.