WD Live wont play large H.264 avi files over 2 hrs long - issue


#1

hi,

i am making H.264 avi files (Mainconcept / ACC Audio) of my VHS tapes using Sorenson Squeeze, and playing them on my WD Live over ethernet from my Qnap server. WD Live Firmware is 1.02.21.

Everything seems to be going great and the quality is excellent of the files. However i did a full render of a videotape the other day in a single file, it was 2hrs20 (an old Eurovision) and the file will not play on the WD TV Live. It gives the message that the media is not supported, which is very wierd. I tried the render again in case it was a render problem. Then i reduced the length of the render to only 1hr 45 and tried it on the WD TV Live and it PLAYED FINE.

So there seems to be a length of file issue with the WD TV Live firmware. Has anyone else experienced this?

I have since tested this with many files and bitrates and file sizes over the past few weeks and the problem remains.

This problem does not seem to be with the SIZE of the file, but the length of the file. ie the bitrate does not seem to affect the problem.

This is not great as some movies go over 2 hrs and certainly i do not want to cut a movie into two half files, it ruins the viewing experience.

Has anyone else experienced this problem?

with thanks,

Blackout


#2

Welcome to the forums.

It’s not a length issue per se –  I have plenty of files longer than two hours that play just fine.  It’s something to do with the file construction, I’m sure.

Try running one of the AVI files through Handbrake (the gold standard of encoding) – use the High Profile preset but output to an MKV file instead.  I’ll bet it plays just fine then.


#3

hi Mike,

thank you for your warm welcome to the forum!

Handbrake does not encode interlaced h264.

why there is not a tick box to process as interlaced i will never know, it de-interlaces everything. This makes my VHS video jerky. I have played and tested this for days. I have tried adding the commands in the advanced box to process as interlaced but they are ignored by Handbrake. i was most disappointed.

Handbrake may indeed be the “gold standard” for movies. But not for TV stuff.


#4

No, it works fine for TV stuff – I use it all the time.

Just use the High Profile preset as I told you – you do NOT want to deinterlace, but rather decomb.  And it’s set correct for you in this preset.  Trust me.


#5

hi mike,

decombing in Handbrake is just a filter that is reducing the deinterlacing artifacts. the resultant file is still de-interlaced.

i suggest you capture some news channel that has a scrolling informantion banner across the bottom, and look at your Handbrake generated file. instead of the words scrolling smoothly they end up “ticking” across the screen.

BAD.

trust me on this one. i have spent many weeks on Handbrake.


#6

What happens when you remux the audio and video into an MKV file using MKVtoolnix (MKVmerge GUI should do the trick)?

http://www.videohelp.com/tools/MKVtoolnix

I have a number of MKV files with h264 video streams that run over 2hrs that play fine.

That should be a lot quicker than re-encoding.  ;)


#7

And if that doesn’t work visit the Handbrake forums –  they are very familiar with fixing any issues with Handbrake deinterlacing things (and I have TONS of TV shows Handbraked and they look just fine, including stuff I videotaped myself and then converted, just like you are doing).

Trust me on this one .


#8

mike : please refer to this post on Handbrake forum:

http://forum.handbrake.fr/viewtopic.php?f=6&t=16009&start=0&hilit=interlacing

the topic is " Can Handbrake maintain  interlacing"

and i quote: “HB does not support interlaced encoding.”

which is exactly what i have experienced. you may be getting files that look ok but they are not interlaced.

i will try muxing my result into a mkv file. that is a good idea.

i thought today that i also try playing the file from a usb stick (as opposed to thru the ethernet port) and see if that makes a difference. i will report back.

thank you for your suggestions.


#9

What’s the physical size of one of these files that won’t play?   Are you using a SHARE, or the built-in Twonky MEDIA SERVER?   Some older versions of twonky won’t play files over a certain size (not DURATION.)


#10

hi Tony,

around 3 gig in size. i tried reducing the bitrate which brought the file down to below 3 gig, but it still did not play. 

then again, if i make a H264 thats 3.5 gig in size (even bigger) it plays just fine, if it is less than 2 hrs! so i have concluded that its not a size issue but a length issue.

at any rate i can play .mpg files that are 7 or 8 gig in size just fine with the WD Live. thats are 3 hours. just not a .H264. Wierd.

(im using a Share, not built in Twonky).

Thank you for your interest 

Cheers,

Blackout


#11

it seems i have found the issue, 

the setting for B Reference frames was 4 in the Sorenson Squeeze template i was using.

for most generic templates on most conversion programs it is set to =2.

I changed it to =2 and did a re-encode and now it works for over 2 hrs.

it is a shame as from what i have read, a setting of B reference frames =4 generally gives better quality video for the same size. It is also wierd that a setting of b=4 is okay for file lengths under 2 hrs, but not over 2 hrs for WD Live. i would assume that either the WD Live can handle a setting or it couldnt, full stop. not this situation where it can handle b=4 frames but “only for so long”?


#12

The Handbrake preset I use has B-Frames set for 3 (and that works for the Live no matter the length) so perhaps that would be a good compromise for you (maybe better quality than 2 but not as good as 4?).

BTW, I understand the stuff I have is not interlaced anymore – what I was saying is that it LOOKS fine.  That’s really the only important thing – a difference that makes no difference is no difference.

My stuff that was recorded on VHS from normal television is perfect with no jaggies or other artifacts – in face, you WANT your video to be de-interlaced (which is why most DVDs of even older TV are indeed de-interlaced).


#13

thanks for the tip re: b=3 mikey. ill try that as a comprimise.

actually if you have taped a movie off TV or a show that was shot to film like Sienfeld then you wont see a difference if it is de-interlaced by Handbrake.

you will with shows that were shot to video tho, such as Alf (off the top of my head) or cheap local productions. So it does depend on the source. Often if its a movie that Handbrake is converting, the movie will look the same but the “extras” that are often shot to video end up looking jumpy. Thats Handbrakes big disappointment.

I can see a difference between interlaced and something that was interlaced and has been de-interlaced, particially with smooth-moving pan shots or as i mentioned, ticker headlines or credits. But thats just me. Many other ppl would not know the difference or see it or care. I just dont like throwing away half of the information.

Mainconcept H264 encoder does an excellent interlaced encode. i hope Handbrake puts an “interlaced” tickbox into its encoder soon.

Cheers,

blackout


#14

I used to work in broadcast television and know a little something about this – let’s just say you and I will continue to disagree (for the sake of others who may view this, I would recommend you DO de-interlace your stuff because you do NOT throw away information and it will look better in all respects).

But, yes, do try the 3 parm because it definitely works in Handbrake with that – and you’ve got me curious enough hat I may try a 4 parm in Handbrake just to see what happens (on a three hour video).


#15

please do try a b=4 render and let me know the results mike. i was using CABAC and a bitrate of 3500.