WD Live wakes from sleep every 30 minutes whenever an AFP share is mounted

I am observing the following behavior with the WD Live (Firmware 02.02.02-020 : Core F/W).  (Note:I have two drives and a friend has one drive.  All 3 drives exhibit identical behavior).  Whenever an AFP share is mounted (on a MAC) - whether the Mac is awake or sleeping.  The WD Live drive will wake from sleep every 30 minutes - like clockwork - for a period of about 12 hours.  The wake seems to consistently occur at 18 past the hour - then it will sleep at 30 past - it will wake again at 48 past - and sleep again on the hour.  This is of course with the drive’s sleep interval set to 10 minutes.  If the drive sleep interval is set to 20 minutes or greater - the drive will literally appear to “never” sleep because of the wake that occurs at 18 past and 48 past the hour.  The 30 minute wake does not occur when mounted from a Windows box - the drive sleeps correctly (assuming because it is an SMB share and not an AFP share on the Windows side).  However, if no shares are mounted (via AFP) on the Mac - and the WD Live drive is used only for a Time Machine backup - the drive will wake to perform the backup - then sleep again after the backup completes - and not wake every 30 minutes.  So something is not quite right with the implementation of an AFP mount  The drive should not be waking every 30 minutes if an AFP share is mounted - whether or not the Mac is sleeping.  After about 12 hours - the waking every 30 minutes stops - but will resume as soon as the mounted share is accessed again from the Mac.  I have tested this behavior over a several day period - and the behavior is consistent on all 3 drives that I have tested (all on the same firmware).  Since I have no experience with a prior version of the firmware - I cannot say whether this was introduced in 02.020.02-020 or not.

I neglected to mention an additional important observation.  With the WD Live drive on a secondary switch - if I disconnect the switch from the rest of the network - the drive still sees a “link” coming from the secondary switch and appears to have no knowledge that it is no longer connected to a computer - and will continue to wake at 18 past and 48 past the hour.  So it is not the Mac initiating the wake - it is the drive doing it on its own - because it believes it has an AFP share mounted.

Remote Access, Twonkey and iTunes functionality are disabled in this scenario so there should not be any extraneous drive activity causing the drive to wake.

Is anybody else experiencing this behavior?  I am able to consistently reproduce it on multiple MyBook Live drives from multiple Macs. 

hi,

don’t know how many times per hour it wakes but if there are all services turned off (iTunes, FTP, WD2go) MBL doesn’t sleep. It’s really annoying.

I did mention earlier in this thread that Twonky, FTP, iTunes Sharing, and Remote Access are disabled.  The wake every 30 minutes is caused strictly by the fact that the drive “believes” it has a share actively mounted via AFP.  I have 3 MBL’s - one is borrowed from a friend - and all behave identically.  I have two other NAS drives (an Apple TimeCapsule and and a DLink DNS-323.  I can mount a share via AFP on the TimeCapsule and it never wakes (spins up the drive) until the share is accessed or something significant happens on the Mac.  The DNS-323 only supports SMB (without a special add-on) and never wakes until it is accessed.

In doing further experimentation since this thread was created - I now have Twonky and remote access enabled on one of the MBL’s - as well as WD Photos and WD2go on an iPhone and iPad.  The enabled MBL is remaining in a sleep state until a request is made to Twonkey or via remote access.  I am seeing that the drive will wake for 10 to 20 minutes once or twice a day - which is fine with me.  It is only when a Mac mounts a share - that it wakes every 30 minutes.  I have the MBL’s on a separate switch - if I unplug the switch itself from the rest of the network - the MBL’s with the AFP mounted shares - continue waking and sleeping every 30 minutes - without realizing they are no longer connected to the Mac.

hmm, that’s interesting. I’m going to give a try to enable Remote Access on MBL and see what happen. 

sbeattie2 thank you for your feedback. 

Okay - one more tip/discovery I have made - slightly out of context of this thread - but when you enable remote access and or twonky - make sure your public share is clean - it seems that any kind of random files in any of the directories under the public share are are subject to being “analyzed” by twonky and/or wd photos - and if there is anything in there that is not a legitiamate jpg, jpeg or some time of media file - it’s going to throw those service processes for a loop - especially if there are zero byte files.  Also - you can see exactly where Twonky looks for media files by going to http://MyBookLive:9000   (if on a mac - use MyBookLive.local:9000 - or whatever you drive name has been changed to.

does it mean that you have nothing in Shared Music Pictures and Videos folders? 

What I was alluding to was - if you remove files from the public share (including the shared_pictures, shared_music, etc.) you are eliminating one more factor in attempting to troubleshoot the sleep issue.  Currently in my shared_pictures folder - I have only JPG and JPEG files - and these seem to be fine and aren’t causing the background process to run continuously and wake up the drive.  When there are other types of files - anywhere out in the public share - whether or not they are in one of the shared_ folders - Twonky and other background processes are still trying do something with those files and causing some strange behavior.  If you go to Twonky setup page via http://MyBookLive:9000 - you can actually tell Twonky eexactly where to look for which specific folders - by default - it is looking in the entire Public share - which in my opinion could create a lot of confusion when users unknowing store non-media types of file in a user created folder with the public share - not necessarily realizing that background processes are going to try to “operate” on those files.

We are now getting off topic for my original post - and should start a different topic for this.

Hi,

I can confirm this behavior. I have the same setup than you do. Macbook Pro (MBP) on switch A <-> switch B <-> MyBook live (MBL) 2 GB.

I also have turned of iTunes, twonky and Web access and mount the MBL on the MBP with AFP. Same bahaviour, Drive wakes again and again even if the MBP is turned of. It only sleeps if I restart the MBL when the MBP is turned off.I did not yet check, if it’s the same 30 minutes cycle, but anyway, doesn’t matter.

I also access the MBL via Apple TV 2G with XBMC via AFP, same problem. Seems to me that the AFP deamon on the MBL is bugged!

That’s a total no go and if this problem persits, I will bring the WDL back for refund to my dealer, because obviously all WDL behave like that.

Regards

tween80

Thank you for confirming tween80.  I will contact WD Support on this.  Apparently posting here on this forum doesn’t necessarily guarantee that any action will be taken by WD - either to confirm or correct the problem.  After recently upgrading to 02.03.01-024 firmware (which I was hoping would resolve this issue) - I believe I am now seeing a somewhat worse behavior when an AFP share is mounted from a Mac.  The MBL drive will remain spun up for about 8 hours - after which point it appears to sleep - until the Mac wakes up.   (tried 3 different MBLs - same issue).  Waking the Mac should not wake the MBL unless you specifically acess the share from the Mac.  At least this is how a mounted share on my Time Capsule (via AFP) or on my DLINK DNS-323 (via SMB) - behaves.

Something is defnitely not right with the AFP implementation on the MBL.

~Scott

tween80 wrote:

Hi,

 

I can confirm this behavior. I have the same setup than you do. Macbook Pro (MBP) on switch A <-> switch B <-> MyBook live (MBL) 2 GB.

 

I also have turned of iTunes, twonky and Web access and mount the MBL on the MBP with AFP. Same bahaviour, Drive wakes again and again even if the MBP is turned of. It only sleeps if I restart the MBL when the MBP is turned off.I did not yet check, if it’s the same 30 minutes cycle, but anyway, doesn’t matter.

 

I also access the MBL via Apple TV 2G with XBMC via AFP, same problem. Seems to me that the AFP deamon on the MBL is bugged!

 

That’s a total no go and if this problem persits, I will bring the WDL back for refund to my dealer, because obviously all WDL behave like that.

 

Regards

tween80

OK. Keep me posted. I also have the latest firmware installed and no sleep. Let me know, if I can be of any help to you.

Regards

tween80

tween80 wrote:

OK. Keep me posted. I also have the latest firmware installed and no sleep. Let me know, if I can be of any help to you.

 

Regards

tween80

Can you clarify whether you saw the 30 minute wake issue before or after installing the 02.03.01-024 firmware or when you were on the 02.02.02-020 only.  Well - you are saying “no sleep” so I assume you are now seeing the “No sleep at all for 8 hours” behavior that I am experiencing with the latest firmware.  Please confirm.  In the meantime I will mount a share on a different drive and see if I see no sleep for 8 hours still.

~Scott

OK! :wink:

Hi, so my Drive with the latest firmware behaves like always, exits Standby at x:20 and x:50 hours, so basically every 30 Minutes.

Heres the log:

Nov 1 14:50:42 localhost logger: exit standby after 63
Nov 1 15:02:48 localhost logger: Enter standby
Nov 1 15:20:54 localhost logger: exit standby after 1086
Nov 1 15:33:00 localhost logger: Enter standby
Nov 1 15:50:54 localhost logger: exit standby after 1074
Nov 1 16:20:06 localhost logger: Enter standby
Nov 1 16:21:07 localhost logger: exit standby after 61
Nov 1 16:33:13 localhost logger: Enter standby
Nov 1 16:50:55 localhost logger: exit standby after 1062
Nov 1 17:12:04 localhost logger: Enter standby
Nov 1 17:15:24 localhost logger: exit standby after 200
Nov 1 17:50:42 localhost logger: Enter standby
Nov 1 17:51:44 localhost logger: exit standby after 62
Nov 1 18:19:55 localhost logger: Enter standby
Nov 1 18:20:56 localhost logger: exit standby after 61
Nov 1 18:33:01 localhost logger: Enter standby
Nov 1 18:50:55 localhost logger: exit standby after 1074
Nov 1 19:03:00 localhost logger: Enter standby
Nov 1 19:07:33 localhost logger: exit standby after 273
Nov 1 19:50:06 localhost logger: Enter standby
Nov 1 19:51:08 localhost logger: exit standby after 62
Nov 1 23:15:49 localhost logger: Enter standby
Nov 1 23:16:51 localhost logger: exit standby after 62
Nov 1 23:33:14 localhost logger: Enter standby
Nov 1 23:50:55 localhost logger: exit standby after 1061
Nov 2 00:20:07 localhost logger: Enter standby
Nov 2 00:21:08 localhost logger: exit standby after 61
Nov 2 00:33:14 localhost logger: Enter standby
Nov 2 00:50:55 localhost logger: exit standby after 1061
Nov 2 01:05:03 localhost logger: Enter standby
Nov 2 01:20:55 localhost logger: exit standby after 952
Nov 2 01:33:04 localhost logger: Enter standby
Nov 2 01:50:55 localhost logger: exit standby after 1071
Nov 2 02:03:04 localhost logger: Enter standby
Nov 2 02:20:55 localhost logger: exit standby after 1071
Nov 2 02:33:05 localhost logger: Enter standby
Nov 2 02:50:55 localhost logger: exit standby after 1070
Nov 2 03:03:04 localhost logger: Enter standby
Nov 2 03:20:55 localhost logger: exit standby after 1071
Nov 2 03:33:04 localhost logger: Enter standby
Nov 2 03:46:10 localhost logger: exit standby after 786
Nov 2 04:20:38 localhost logger: Enter standby
Nov 2 04:21:39 localhost logger: exit standby after 61
Nov 2 04:40:53 localhost logger: Enter standby
Nov 2 04:50:55 localhost logger: exit standby after 602
Nov 2 05:03:13 localhost logger: Enter standby
Nov 2 05:20:55 localhost logger: exit standby after 1062
Nov 2 05:33:04 localhost logger: Enter standby
Nov 2 05:50:55 localhost logger: exit standby after 1071
Nov 2 06:03:04 localhost logger: Enter standby
Nov 2 06:20:55 localhost logger: exit standby after 1071

Regards

tween80

This log is really handy.  How exactly are you getting to the log?  I assume you have enabled ssh and are simply looking at the log file?  What is the log file called and where is it located?  I will take a look at mine once I know how to get to it.

No it’s much simpler, go into your browser and type the IP of your WDL. Then go to “Support-Create&Save System report”. Then a zip-File is downloaded, unzip it and in the Log-Folder you can find the file called “messages”. That’s the log file I looked into, you can look through many others within the zip-file!

Thanks.  Okay - I have actually done that before - and just wasn’t sure which log files were which.