WD Live TV SMP NOT detecting wireless network


I will try to sum up all the things I have tried so far…

First of all my hardware

Linksys E900 Router Basement
Linksys EA4500 Router Ground floor

WD TV Live
WDBGXT0000NBK-01 in my living room Running FW 2.01.86

WDBGXT0000NBK-02 in my bed room Running FW 2.01.86

The WDBGXT0000NBK-01 can see and connect to all my wireless networks (2,4GHz) and also wired

The WDBGXT0000NBK-02 can sometimes see the wireless networks (2,4 GHz (Never my 5GHz)) but when I try to connect it just asks me to try again… - It works wired (Both static and DHCP)

I have tried to give it static IP, but that doesn’t help either…

Everything have been powered down over night (Modem, Router, WD) and the not working WD TV Live box have also been resat completely.

The “fun” part is that if I share the network on my HTC One the WDBGXT0000NBK-02 connects right away…
So it only seems to be a problem when connecting to my Linksys routers…

I have tried EVERY different settings on the routers… 20MHz, 40MHz, all different channels… a, b, g, n
2,4GHz 5GHz - And all DHCP adr have also been deleted

I also forgot to mention that it has worked before with the exact same setup…

What to do???

Kind regards


Well, for one thing, don’t spend any time trying to connect to 5GHz networks.  The WD TV is 2.4 GHz only.

Thanx, figured :wink: :slight_smile:


No one has any input!?!?

make sure you give the devices different names

besides that, I don’t know, maybe the wireless signal is too weak to actually connect to it

or possibly some problem with the 2 routers, I assume, one is running as a bridge

Hello Kad,

Thanx for the reply…

Both routers has been hardware reset and reconfigured after I had tried to clear the DHCP listing of previous devices without any luck… - I have also tried to turn of one of the extra router…

Both WD devices has different names… one is called WD Basement and the other WD Livingroom

I have tried both WD Devices in the Livingroom some 4m from the wireless router…
They both have full signal on reception… The one that doesn’t connect only see the SSID sometimes… and it is always vissible on the WD that works…

Thanx for the reply :slight_smile:

Best regards


Anyone else…???

Am I missing something here or isn’t anybody able to help at all!?

If no one else here has had the issue, then no one here is going to know what to suggest.

probably not…
Better return it to the shop then…