WD Live TV HUB 1TB Netflix picture not showing

I just starting using (or tried to) Netflix streamed through my Live TV Hub.  I am able to log in, browse titles, etc.  When I select a show or film to watch, after it loads, the screen fades to black.  The sound comes through just fine.  It is baffling to me that the image would fade only when a show starts.

Any thoughts? Thanks,


How is it hooked up to your display?


It’s hooked up via HDMI with RCA going to my surround sound.  Latest firmware update was performed just a couple of days ago.



Make sure that the input your WDTV is plugged into supports HDCP.

Still trying to stream Netflix through my Live TV Hub…

I have not yet been able to stream Netflix successfully throught my Hub.  To recap, here is what happens.  I select services, Netflix, have entered my account information (all visible on the screen), browsed TV shows and movies.  When I select something to watch, the title of the movie and “loading” bar appears.  Once loaded, the show starts.  The sound comes through, but the picture fades to black.


HDMI to TV  (I have tried 3 different cables from two manufacturers, in three different HDMI ports).

RCA to surround sound (which is where I get the sound - nothing through HDMI through TV, if RCA disconnected)

RCA video to TV - I do get a picture!!! But, it is of terrible quality as expected.

TV is a 2010 Sharp Aquos quattron 40" 1080/120

I have rebooted/reconnected everything several times.  What is confusing to me is that I can get a picture via HDMI to view menus and browse movies/shows, but that it fades only when the movie starts.  I have no problems streaming other services (such as Youtube/snapfilms) via HDMI.  Just spent 45 mins. in online chat with Netflix support… Still no picture…

Any other thoughts?  Thanks in advance…