WD Live TV (Gen2) doesnt play photos or video anymore and doesnt connect to network anymore :(

Hi Forum

My baby WD TV Live  HD doesnt play avi files anymore. This is the Gen 2 (the one without the wireless connection). Everything was working until one day I came home to find that my ADSL modem/router wouldnt connect to the ISP. After much troubleshooting, the ADSL/Modem router was replaced under warranty. Then I found that my WD TV Live wont play any avi files or open photos. These are the same files that I used to be able to open previously.

When I plug in my usb drive, I can see the preview of the photos however when I open them, all get it the spinning wheel and that just keeps on going on and on.

For avi files, when I open them, it says the file format is not supported. However I used to be able to open these before :frowning:

My WD TV Live is connected to my ADSL/Modem router using a network cable but it cannot connect to the internet anymore. I found that the MAC address for the network adapter is listed as 00:00:00:00:00:00 and the lights dont come up at the back where you connect the cable.

I have upgraded the unit to the latest firmware however this hasnt solved the issue.

I tried playing the same files on my friends Gen 3 WD Live (with the wireless connection) and they work fine.

Have I lost my WD TV for good or is there anyway to revive it?

Please help:cry:

Have you try playing similar files over the network?

If the files were playing before it looks like the unit is going down

Hi Wizer.

Thank you for your reply.

Unfortunately I cant play over the network since the network adapter doesnt work anymore :frowning:

Is there a way to erase everything from the WD and then upload a fresh firmware?

There’s nothing to erase

You can try to update the firmware via USB

please go to the webend interface and use the configuration tool

on the last tab there’s a button that says “Delete EVERYTHING”

this will delete the entire contents of /conf

it actually does this

rm -rf /conf/*
sync && sync

Hi KAD79

I wish I could do that :frowning: Alas the network card doesnt work anymore so I cant get to the web page

Just realised that I had another thread open on this. Best update both incase someone finds my thread useful.

KAD79 you are the man!

Your solution was spot on except that the nic card on the WD TV Live is not working anymore so I couldnt get to the webend. I had installed wdlxtv however that hadnt fixed the issue.

However, not wanting to give up, I did some research and found that I could add a wireless usb adapter to the unit. However not all wireless dongles are supported. Then someone mentioned on their blog that those with ralink chips are good. I remembered having one just like that … and viola! I was connected.

I went via the webend to the Config and then reset everything (downloaded the backup before doing this :wink: ). The restart after that took abit longer (4min with NO SIGNAL shown on the tv screen) but after that I could play my avis and mp4s … yay!!

Too bad the NIC is still busted but with the wireless usb … I am almost all as I was previously

Thank you thank you sooo much

PS. Wish wdlxtv would be able to crack the encryption on WD TV Live Streaming (gen3) so that I could get it on my friends unit