WD Live TV FREEZES when ejecting USB Flash Drive - SOLVED

This is interesting, as it has always been happening in my case and with various flash drives.

What works is simple.

If you STOP playing your video BEFORE it ends and goes back to the file selection screen,

you should be able to safely eject your flash drive. (Lexar 32gb USB3, CoreMicro 32gb USB2).

This procedure has worked every time for me so far. If the file plays through the credits and then goes back into the file selection screen, the system will freeze when you try to eject either flash drive.

This proccess does not seem to apply to the 2 powered external devices I have(Iomega 2tb, MyBook 2tb), only the thumb drives and possibly not everyone of them…

The question now is if it is simply a compatability issue with certain flash drives, why does it work following a different approach? Can anyone explain this at WD?

This indicates that MAYBE it is a firmware / software problem, or both.



Have you checked if you have the latest firmware update? Have you also verified if the problem happens with all of the movie extensions?

This can also happen if some remote device (a PC or something) is accessing the flash disk via the network and holding a file handle open.

Yes, latest firmware. The files are mostly HD.mkv movies. Not tested with any other format.

My player has not frozen once since following this approach. Using various thumb/flash media including ones that have frozen the unit in the past.