WD Live TV does not show file on My Book Live

I have a 2TB My Book Live where I have a bunch of my video files.
I recently added a video file which was in MP4 format and it will not show up when I search that respective folder on the MBL.  I added a video file in AVI and it shows up no problem.  Keep in mind I’ve had these items for atleast a year and haven;t really encountered any problems until now.

Here is what I’ve tried thus far

  1. Cleared the media library on the WD LiveTV (through Home Screen -> Setup -> System -> Media Library -> Clear Media Library)
  2. Turned off the WD LiveTV
  3. Completely rebuilt my twonky library on the MBL (through the Dashboard–>Settings–>Media–>Status–>Rebuild)
  4. Turned on WD LiveTV and the file is still not showing up.
  5. I renamed the file and made a copy into another subfolder and that didn’t help either.  

What is going on?

Well, you’re doing things that don’t relate to each other. If you’re using Media Library, then Twonky isn’t used at all. Twonky is if you’re connecting via Media Server.

So which method are you using?

I’m using the media library I guess.  I choose “videos” from the main screen, then chose MBL (which I’ve named WD2TB).  I scroll to the appropriate folder and of course I don’t see the file, but I know the file is there since I see it on my desktop.

I also made sure that the WDLiveTV scans every hour for new media.  That doesn’t do anything either.

If the first thing you see is the name of your NAS, (not the share name) then you’re not using Media Library.

Press the RED button…what do you pick?