WD Live stuck

My WD Live when booted up and connected to the internet goes directly to the firmware update icon, but will not let me select it…just freezes.  If I disconnect it from the network and try updating firmware with USB stick it gets to the rebooting screen and freezes.  I tried 3 different usb sticks. Formatted both fat 32 & ntfs, and tried both usb ports. Also I am only pitting the 3 files needed on the usb drive. Gets to reboot screen & freezes.  I tried holding in the reset button and doing a hard 30/30/30 reset and I also tried going to the factory reset in the settings, but when I select ok it freezes.   Any ideas ?


I think i would take it back to the shop and get it replaced for a new one.

I was hoping there was some sort of fix I could try.  I bought this unit a couple years ago on Newegg, so returning it is not an option. 


goober055 wrote:

…I bought this unit a couple years ago on Newegg

… then you are in the wrong forum.   This forum is for the WDTV Live Streaming Media Player which was released in late 2011.

The forum for the 2009 model WDTV Live HD is here: