WD Live Streaming Player not recognising HDMI

Hi all,

I’ve posted this previously almost a year ago (although the link from my emails now tells me the message is no longer available) and unfortunately nobody could help me.

My WD Live Streaming Player was working perfectly fine for over a year and then one day without me changing anything it suddenly stopped recognising the HDMI cable and ever since I can only use it with the composite cables. I have done all the factory resets, used different HDMI cables and different TVs so there is no use suggesting any of those options.

Looking at some of the other topics on this site, it appears quite a few others have had the same problem but nobody seems to have successfully fixed it.

It is very frustrating not to be able to watch in HD. The unit is past the warranty period so I can’t get it replaced. I’m about ready to throw the towel in and buy something else but I have noticed that many other players these days are all about the streaming and don’t support the local storage (I have everything on an external HDD) so I still think that the WD is the most suitable player which makes it even more annoying thinking that I may have to buy the same unit again when it is still perfectly fine apart from this problem.

Can anyone PLEASE help??

Thanks in advance.

Is the HDMI output not recognized at all? Not even if your first set a low configuration via composite or component? 

Thanks for your post. The TV recognises that something has been plugged in via HDMI, as the HDMI 4 (or whatever number port) shows up on the screen but then it says it cannot connect with the device and the TV screen remains black.

If I have both composite and HDMI connected and I try to change the settings on the WD from composite to HDMI, as soon as I confirm it, the screen flashes off and back on again and the WD settings menu has changed back to composite. I have tried unplugging the composite as soon as I hit confirm and then go to the HDMI source on the TV but it just does the same 'can’t connect’t thing as before.

I really feel like I’ve tried all (fairly obvious) avenues, so unless there is something obscure that I haven’t thought to try, I think my unit is just broken in a very strange specific way.

It’s sounds pretty strange, definately not normal …

The only thing i can think of as a last resort try … is using KAD79’s Alternative Full Reset


Unfortunately that didn’t work, well not entirely anyway.

Once I completed the reset as per those instructions I was actually able to connect through the HDMI cable and it all looked great. But it kept flicking on and off, so I would only get about 10 seconds of picture before the screen went black as it tried to connect again. Then after a few seconds it would come back on and so on.

So I performed the reset a second time and now it is back to the way it was before - no ability to connect through HDMI at all.

So annoying…