WD Live Plus Not recognizing MKV files

I have the WD Live Plus. I have a computer which is WIN7. There is a WD External drive which is plugged into the computer but it won’t recognize the MKV files.

I have the Drive as well as the Folders set to SHARE. I can go through the SERVER selection to the MOVIE Folder. But it will not even recognize there is an MKV file. However it does recognize and play the MPEG4 file in the same folder.

When I plug that same external drive directly into the WDlive USB port it will play the MKV files.

I have had it working in the past and have even resorted to Restoring the Win7 machine to the Restore Point when it was working a few weeks ago.

I have also just tried doing the Update to the Firmware 1.06.41 which I just saw on your site. Still no luck though.

Obviously something in Win7 Sharing. Which I have changed the Sharing so it did not require password to share.

Any help much appreciated.


Are the mkv files large (more than 2.5GB) ? …cause I’m having the same problem.  Files less than 2.5GB will display and play fine.  MP4 files display and play just fine any size.

You say you’re going in via Media Server, which means whatever media server you’re using on your PC must support MKV files.

If you’re using the default Windows Media Player as the server, it does NOT support MKV files by default, and you must install codec packs to get WMP to work with MKV.

Use network shares.

Sorry have been away.

I don’t have any MKV less than 2.5GB so can’t answer that one.

I installed XBMC Media player on my PC and can play the MKV’s.

On the PC i have tried a number of things with the Shares but can only read MPEG4 and not MKV even when i have them in the Same folder on the E:\Drive

Are you connecting to your PC via network shares.

Yes i have the External Drive connected to the USB of the PC and Shared. I also went into the Advanced option and added Shared with everyone.

This is where it is strange because I can get to the Folder and watch MP4 files but don’t see MKV files.

Also i have to do it through the Server selection not the WD network Shares in the WDTVlivePlus.

toddyt >>>>  Also i have to do it through the Server selection not the WD network Shares in the WDTVlivePlus.

Why do you say this? 

You should be able to do this, and you have to view certain files via Network shares, and not Media server.

As has been said, you connect to the hard disk connected to your PC via network shares. You select that option via the WD player. Do not use the media player option as it obviously will not serve your mkv files.

What do you see when you select the network shares option on the WD player?

Out of curiosity, try putting a smaller mkv file in your shared folder (like 1 GB) and see if you can see it on the WD.

Yes I have had the WDLIVE for a year or 2 and I used to connect to the Drive through the SHARES.

I just purchased a Raspberry PI and when I connected it the first time it detected all the Movies. But I had a problem with it and went back to the WD and now they both do the same thing. Neither device detect the MKV files.

I believe I said before that if I plug the hard Drive into the WDLive it detects the MKV files no problem.

I don’t have an MKV smaller than about 4gb. Will try to get one and try it.

I believe it is something in the Window 7 but can’t figure it out.

OK, so I wondered what a Raspberry Pi is, so I looked it up.

Maybe it trashed your hard drive containing the MKV movies when you hooked it to the drive for your WD movies.  Maybe it wrote some strange files on the HD that confuses the WD.

So, try this:  remove the HD from the devices and hook it to your PC.  Delete the .wd_tv folder.  Also, scan your disk for any errors.  If all checks out OK, hook the drive back to your WD unit and let it boot and re-write the .wd_tv folder.  When finished with all this, try to play your MKV files again.

I converted a file to 800mb and it still didn’t detect it was in the folder.

It also won’t detect the MKV’s on the PC HD either.

I have tried deleting the WD files off the External drive before. Still didn’t change.

May or may not be your issue but when I had a folder full of video files where only a few wouldn’t play (they were visible but clicking on them resulted in a “not recognized” error) it turned out to be file permissions related. My files reside on a QNAP NAS and the files that couldn’t be played had different UNIX file permissions then ones that would. Once I allowed group and other “read” permissions, all worked OK.

I ssh’ed into my QNAP and performed a “chmod 644 *” in the directory.

Again - Likely not your issue. Just my 2 cents :slight_smile:

No I only have a Win7 PC so no UNIX.

Thanks anyway.

When i get home tonight i will try deleting the WD.Tv files of the Main Hard Drive as well as the External. I had done that the other day on the external but not the Main HD.

Well still no luck found there is not WD.TV files on the main HD. So that was a wash.

Have tried deleting and installing the Network drivers.

Tried changing the Workgroup name on both devices.

Tried installing Netframework 4 even though i have no idea if that has anything to do with it.

It shows the folders which are shared through the Server tab but not listing MKV.

Now it does detect the PC through the Network Shares, But can’t access anything and come up with access denied when i click on the PC.

In your first post you said you’re accessing the PC via the “Server” function.

Does that mean you’re using the “Media Server” menu item on the WDTV?   If so, then the MEDIA SERVER on your PC doesn’t support MKVs.   If it did, it would list them.   You need to either fix your media server, or use the “Network Share” function instead.

Yes that is correct it is the Media Server Selection which i have to use.

But that is because there is something on the Windows 7 PC whichis not allowing the Sharing.

When i go to the Network Shares it shows the PC, but that is as far as the sharing will allow me to go. Can’t see any folders because i get access denied when i select the computer.

Then you need to fix your media server, as IT is the reason why the WD isn’t displaying the MKVs.  The WD doesn’t even know there are MKV files there unless the media server offers them.

It is not actually a Media Server it is just my PC.

I realize it is my Shares which are the problem just was hoping someone had suggestions on how to fix it!