WD Live Plus HDMI to tv and optical to receiver. Cannot get audio on just optical


#1

My setup for my wd live plus has my hdmi going directly to my tv and the optical going to my receiver.  I select “Digital without HDMI audio” in settings but I’m getting both audio stream at one time.  I would like the hdmi cable to just carry the video and no audio but can’t seem to turn  the audio off.  Any ideas how to fix it?


#2

That’s the correct method, but apparently, that setting doesn’t work.


#3

I don’t have a Live Plus, but as far as my experience with the Live goes, the sound output depends on the condition of the Audio track itself!

I don’y know how to put it, but you’ll be ok with  5 ch AC3 or AAC but as long as your audio stream is not digital (I don’t know why they won’t call it digital, because it is!) your device will ignore your “digital out” setting and you will have audio on your HDMI too. the sign is, while starting playback of your file there will be an OSD text such as “5 Channel AC3 (Digital)” but for some, you won’t see that little Parenthesis there, which means your stream will remain Analog and here we go the HDMI audio. I think your setting is only applicable on some sort of audio encoding and conditions, otherwise, it’ll be overridden. 

I know, it ■■■■■ really hard, but I can live with that!