WD Live locks when network cable plugged in!

I have a wd TV live (not plus) that had worked fine until recently.  I moved it to another location (different TV, network cable, receiver) and had it freeze once I plugged in the network.  I returned to my original location where it had worked and now it is not working there. 

What it does: 

  1. If I plug it in (to TV, power, receiver which is HDMI) it boots up just fine and I can go through menus, etc.

  2. When I plug in the network cable, it freezes up.  Remote does not work, resetting does not work, unplugging and replugging does not work.  Always comes up frozen. 

I have tried resetting button and entering network addresses manually prior to plugging in network cable but to no avail. 

This is useless without access to my network for files on my NAS. 

Is there a way to reset this or troubleshoot this that I am missing?

Anyone else have this problem?

Any help is appreciated…would prefer not having to buy a new one…:slight_smile:

I suppose there is a possibility that you damaged it when you moved it. You can only really do the reset on the side and reset to factory defaults in the internal menu. You could also unplug from power for some time.


  • check so called “media library” functionality  - maybe the wd is checking them [medias] - and it takes enormous time [to do so and that is why it freezes]  - so   =>   on screen in options pls uncheck “media library” and check again