WD_Live Hub no longer shows up as a drive in my computer

I am using Windows 7 Ultimate 64-bit.

I joined a 2003 domain for a class I was taking, and my drive stopped showing up as a drive in My Computer.  I have since unjoined that domain, and it didn’t come back. 

I can go into networking setup and see it as a Network device when I do a Network Map.  I can bring up its web page in my browser.

But when I go to My Computer it does not show up as a hard drive, nor does it show up under Network on the left pane of the window.

I reinstalled the driver.  And the driver is there…and working…  But still no WD drive in My Computer.  This is very inconvenient for me, because I usually move stuff I recorded on a DVD camcorder to my drive by dragging and dropping the files.

Have you try to use the WD Link software?


This might help you to discover your Hub.

Also, have you check your WD TV Live Hub network settings? Do your computer and Hub have the same workgroup name?

Thank you very much! Not exactly the resolution I was expecting…but actually much easier than what I was expecting to have to do… So Bravo!

Hello Peepws, new here…I have had my hub for going on 6 months now and now for the past week I have got the issue of the Hub not appearing on my computer.

The solution given on this thread does not work for me.

Guys, I have similar issue, equipment was working fine, but since last week, I can not connect to the WD TV live hub from my PC, I have Windows 7. I see it mapped as drive Z, ut all time it shows disconnected.

Yesterady I was trying several thinks but nothing worked, I eliminated drive Z, then I was trying to map it again, but device isnot recongnized (or the address), I can see the device when I go to networks on the windows explorer, but if I make double click on it I just got an error thet address cannot be found. I was unable to map it again. Using application Wd discovery I can not see the device, even I install WD lonk and nothing.

On the device I check and it shows that network settings are OK, I got IP address, sub net , etc. I can conet to the services on iternet. But I can not connect to the device from my computer. I tried with my wife’s computer  (windows 7) and the same.

Not sure if this could be related with any upgrade or something like that.

Could anybode provide help here?

Thank you…