WD Live Duo World Edition (white) not booting


I’m having some trouble with this, was working in December when I connected to it from my TV for the first time, but just tried to access it again and it didn’t look like it was booted (only ethernet green light on back was on).  Checked leads and switched on using the power button on the back and only the bottom lights would flash on, then the top few quickly before going back to the state where the only life in it is the green ethernet light.

I don’t know what firmware is installed, cant tell a thing at the moment, all I know is that my tax return is due at the end of the month and all my documents are stored on that hub.  I’ve got originals and older back ups but don’t think I’ll be able to replicate the work in time to file!

What can I do that won’t re-format the drives?  I’ve had this unit only around a year and it’s caused me nothing but problems, for a box that supposed to sit there unmaintained and act as a safe cloud storing your digital life this has been limited in use to the point of uselessness.  I should have known from the initial ‘ah, no sorry itunes won’t work’ issue that it was a very bad buy. 

Anyone any ideas?  Thanks in advance.

Sounds like you have a similar issue to mine, albeit a diff World edition.

Same issue here. Single drive white stripe version…just get a little action when turning on then disk spins down and all quiet. Small green LED at network port glowing. Have only recently upgraded firmware to try and get timemachine working with it…but was still having issues (something wrong with the volume’s CNID DB…). I shut down the drive via the web portal and it hasn’t powered back up since. Fortunately - because I was about to do a complete restore - I have copied all data onto local drives so I haven’t lost anything. The whole reason why I started doing this was because WD Anywhere Backup didn’t appear to support multiple users and had stopped backing up my files a month or so ago…I only discovered this doing a routine check. I’m off to buy someone else’s NAS (ie; not WD’s). 

I had another look at mine today and manager to get it working (finally)!

Someone on another thread mentioned holding the power button for four seconds causes a reboot.

I switched mine off and unplugged from the network then held down the power button and it started looking like something was happening (I wasn’t expecting much so had done this in another room away from network access - clever me)! I the. Switched off and moved back to its normal environment (with network cable etc) and its now working (picked up by all machines that had previously used it and no data lost).

I don’t know what caused this sudden loss of connection but in my case a month of telling everyone it’s rubbish (including a national technology magazine who published my complaint) then returning defeated a month later did the job!

I’m now only going to store stuff that’s backed up elsewhere or unimportant, I don’t trust WD anymore.

Yes I too was experimenting with that power button at the back. I held it down FIRMLY for several seconds when it was powering up and to my delight it came back to life. AND everything was still there on the drive. I haven’t found this trick documented anywhere. I performed a factory re-set through the UI to get rid of those CNID DB messages Time Machine backed up last night - so happy days…EXCEPT i’ve discovered the Time Machine *.sparsebundle file will keep growing until there is no more room left on the drive. So that’s not great because I want to use the drive as a media server as well.

I’m now taking a similar strategy to Liquidfirell. I’ve signed up to JustCloud for my bulk enterprise grade storage needs and I’ll supplement that with my My Book World/ Time Machine backups. 

Oh well, I guess the drive is a few years old now and has given me adequate service to date.  

For the benefit of readers…you can use the Apple Disk Utility to limit the .sparsebundle size. I found this link in the Apple communities forum which solved it for me:  http://pondini.org/TM/A8.html

Glad you’ve got the drive functioning partially!

I down have any experience with time machine, I figured I don’t really need it if the drive does regular backups of my stuff so can’t really help on that front but if you’re backing up all the time could you not use the USB slot with a smaller stick and tell TimeMachine to use that smaller drive? If you back up in the background then I’d have thought you wouldn’t need a whole lot of manovures recorded to rewind through.

Interestingly we have just upgraded our server to Mountain lion and are getting the same doubling of files until space runs out on the ram for work group manager (which stored all user info). So I do wonder if your issue is an Apple thing (believe it or not they make mistakes)!