WD Live connected to WD external elements HDD

Hi All, I may have missed something here … I have connected my WD 2.5TB external USB HDD to WD TV Live streaming media player, connected via HDMI to plasma. The issue is when I go to any menu option - Video - Media Servers - and hit OK, an error message comes up "“The device could not connect to the network” Am sure this is an easily fixed issue, though after some time I can not figure this one out … Have update to latest firmware to support HDD above 2TB Firmware - 1.06.15_v When I plug in a USB key with photo’s the content shows with no issues, only my external HDD content isn’t recognized when plugged in via USB … Can anyone help? Many Thanks :slight_smile: Faerie

If you have a USB HDD plugged straight into your WDTV then you’re looking in the wrong place. You’ll find the folders on your USB under ‘folders’ and any films on it under ‘All Video’. Well, that’s what they’re called on the old model - it’ll be something similar if not exactly the same on the new one. Sorry if I’ve misunderstood what you’ve said - but give this a go. Steve W

Right, you need to press the RED BUTTON to change the source to the local USB drive.

Thank-you Steve & Tony for your response & clear instructions… tho am still lost. The main menu on the WD TV Live is very simple - it only has the following menu options - Video Photo Music Settings - Audio/ Video - Video settings - Photo settings - Music settings - File management - when I click on this it says Select source / No storage present… this tells me it isn’t picking up on the USB drive as you refer to Tony - you mention Red button - on remote of WDTVLive remote? The only red button there is Power and I tried powering off and on which doesn’t change the outcome. USB HDD has no remote or buttons. Games Internet Media Part Number of WDTVLive - WDAAP0000NBK (when search on this P/N no results were found?) The box says WDTV Live Network media player, though when I search this product name on WD website it shows the streaming media player product, so I hope it is the same product? Sorry if I am coming across silly - the WDTVLive has a different looking Home menu to the online WDTVLive manual I downloaded & trawled through last night before posting my help request … and to the one you mentioned Steve, so yes must be a newer version. Tried resetting to factory settings, this didn’t work either … Thanks Guys for your help, any more thoughts or ideas on this one? Faerie :slight_smile:

Am thinking it is the way my colleague put data on the HDD … first it was loaded with movies, then he went and loaded music through his MAC.

I then asked if he could reformat the HDD from MAC to Windows (not that I use the HDD with any computer) and he reformatted to both MAC & Windows so it is in FAT32 I think… perhaps it needs to be in NTFS instead for this media player to read?

The only other concern is when I first plugged HDD into media player a week ago it wasn’t reading it and an error message on media player - “does not support higher than 2TB” which is when I unplugged HDD and upgraded firmware on media player.

I hope by plugging in HDD to media player on old firmware hasn’t corrupted it?

Thanks Guys


The WD firmware update “1.06.15_v” was and after months (!) have passed by now without any action from WD Support [apart from probably having to upgrade their Server capacity to manage/handle the thousands of  posts from frustrated users ;-) ]- still is the latest firmware version posted.

Admittingly a few -mainly cosmetic- bugs were fixed in that release but some major flaws were introduced rendering the device useless for many of us.

Many experienced -if lucky- a very slow mounting process of external (WD) drives, if unlucky drives are not mounted at all.

In addition lots of files working just fine under earlier releases,  totally crashed the player (req. reboot with very very slow mounting of drive) .

Hey but at least the Status Info did now update nicely ;-(

Somehow I get the impression that after this total fiasco with obviously no in-house testing prior to the release, they are either now testing without end or no one has the guts to actually write the next firmware.

The product live cycle seems to be also close to or already over its end with more powerful devices on the market for similar bugs.

If so, could someone at WD  please take down this release - my little ones have on countless occations confirmed the sneaky upgrade confirmation by accident.

Easiest Solution: Downgrade to previous Version as per very detailed instructions in the WD Forum and do not get anoyed by the “a new firmware version has been found”  nagscreen every time you power on.

As for drives >2TB capacity, major issue and based on their scarce replies, WD seems to have no intention to fix this.

Even if drive is “divided” in <2TB Partitions, can almost always not mount.

FAT32 is a no-go for big drives, NTFS is the norm. Apple and Windows 7 offer the choice of EFI - again not the best idea with this player.

Checking the drive for errors incl. fixing option (under Windows) is reported to help in many cases as well.

So downgrade firmware, file system error check and drives <= 2TB and the thing works like the charm which made it famous once.

Best regards

It appears that the original poster has a WD TV Live Media Player and not a WD TV Live Streaming Media Player. Therefore this issue is in the wrong place. However there is no way of reporting an issue with a  WD TV Live Media Player so there is no way of transferring it.

WD have completely confused everybody by using pretty well the same terms to describe two different media players. This forum is for the latest Live Streaming Media player only.