WD Live changing files to 0 bytes

I have had the WD Live since Christmas and I have had no problems with it until the last few weeks.

I recently updated the firmware so I could use two new usb 2.0 2.5 tb wd hard drives. I backup my movies on both drives.

I noticed recently that after using either drive to watch a movie that some of the files were 0 bytes. I never had this problem with my other 4 2 tb wd drives.

Should I partition the drives into two 1.5 tb drives so the WD Live doesn’t have a problem with it?

The WD TV should not have any issue handling 2.5 TB drives, have you tried checking your drive for errors?

Unsupported file types will be reset to “0”, even if you have not played them.

All you need to do is enter the folder and the player will scan the contents and reset the files…

I think your seeing the same problem as me with “Unsupported file types”

We need to figure out what it is about these files that are now unsupported.

It may or may not be related to the latest firmware release, but that is also the one I am on: 1.06.15


I checked both drives for errors. There were no bad sectors on either drive. There were file system errors. I fixed those and the drives seemed to work fine.

I used one of the drives with wd live and things seemed to be fine the first time. The second time I used wd live it turned one file into 0 bytes in a folder I did not access. I scanned the drive again and file system errors were detected again on that drive.

I’m having the same problem. It’s very disconcerting to know that my WD box is going to randomly delete files on me, as I generally keep my backups on that same drive.

edit: For what it’s worth, my file was an mkv. And it’s the first time I had ever seen the WD box do this. My drive has no issues, but I did download the file a 2nd time, and the WD box did corrupt it again a 2nd time. I didn’t get a chance to see if the file played properly on my computer, but I have no reason to believe it wouldn’t have - I’m not going to waste another hour downloading it for a 3rd time though.

This is happening to me as well.  It’s a very small percentage of files, but still, it flagged and zero sized at least a dozen of them.  They were all mkv files, and all were zero sized as soon as the WD unit read the file directory, I didn’t need to attempt to play them for them to be wiped.  I guess in a way that’s a blessing, at least it doesn’t happen randomly if I try to play a file.  Still, very disconcerting and I don’t want the unit deleting my files without my express command and consent.  WD, are you working to fix this?  It’s only been a problem with the latest firmware update - before that everything was fine and in fact I had played all of the files that were wiped on previous firmware.  Why are these files suddenly unsupported and wiped from the drive?

I have the same problem too.

How big is your hard drive?

My hard drive is 1TB. I don’t think size has anything to do with the issue. I have been using this drive fine for over a year. I have put files on it since the file I had problems with and had no problems with other files. The WD box is most likely corrupting mkv files that it doesn’t support playback for - it should not be writing these files though, regardless.

Check this link for the similar problem. Read though it as this solved that problem for me.


Basically, you want to Check the drive for errors, then “Re-Load” one of the problem fils to see if it works.


Just wanted to bump this, and report that it doesn’t only happen with mkv files, it also just now happened with an avi file I tried to load up.  Also want to report that while it only happened to a very small percentage of my existing files (maybe 1-2% total), it is happening on a very frequent basis with new files that I copy over (at least 50%, maybe more).

Anyway, thanks for the tip on the other thread, kidknicky.  I will read it through and see if it helps and report back here.

WD:  what are you doing to address this issue?  Your firmware should NEVER delete or zero-size any files without the user’s express command.  Even if the player couldn’t play a file, it should leave it untouched and simply report that the file can’t be played.  Deleting user files at random and without permission is a real deal-killer for this otherwise fine player.  I would really appreciate if an admin or WD rep could comment on this thread with an update, or at least an acknowledgement that this issue is recognized.  Thanks.



WD:  what are you doing to address this issue?  Your firmware should NEVER …"

Listen, I don’t think it’s a WD issue at all. People having this problem should report their drive type and results to this tech I am describing here:

My tech:

  • problem is re-occuring, drive is an “Iomega Select 2Terrabyte” (hitachi drive)

  • after “CHKDSK” scan ERRORS REPORTED and repaired, files re-extracted and play fine…


  • scan drive PRIOR to extraction, ERRORS FOUND AND REPORTED/REPAIRED, files extracted and play fine.

So what you want to do is scan your drive as soon as you plug it into the P.C.

Tell us if you are getting error after this step, then go ahead and extract and play / test file.

I believe this is specific to certain portable drive types. It does not appear to be a file type issue ar a WD Live player issue. Errors are ocurring AFTER the drive is being connected to P.C. (WinXP SP3). WD Live player also reads the error and resets byte to “0” (a good thing, I think…).

Everytime I plug my Iomega portable into the P.C. I scan it, get the same error’s, REPAIR then extract and all is fine.

Testing on 2 other portable’s I have, both are WD portables but untested so far. I haven’t had a reason to check them either…

Hope this helps !


      You wrote>>>   as I generally keep my backups on that same drive.

Duplicate files on the same drive are not “back-ups” they are simply duplicate files.  Back-ups are only back-ups if they are on a separate drive. 

Your are dissing the WDTV box unfairly.  The WDTV does not write to video files, audio files or other media files.  It writes to it’s own files only; the ones keeping a record of the library of files on the given drive.

     You wrote>>>    I’m not going to waste another hour downloading it for a 3rd time

Perhaps the files you are downloading are corrupt, or the downloads do not complete or terminate correctly for some reason, and all you end up with is a file name but there is no file (i.e. zero bytes)

People who download pirated video (and audio) files from the Internet have no idea of the quality of those files, and so get what they pay for and deserve what they get.

No, most are not bad files, it is something else…

I also tried numerous downloads until I figured it out…

I am not a pirate, but enjoy many HDTV programming not available to my area or access…

Please do not judge people, but instead, try to stick to topic and assist with results and info,

Just ignore what is “OFF TOPIC”

How  do I check my portable drive?





Be sure to check “Automatically fix file system errors” only when using Check Disk options…

How do I get / read my errors ?

Follow this:



Performance and Maintenance

Administrative Tools




Pay attention to time and date to get proper info


Oppologies karma1969, this does in fact appear to be a “WD TV LIVE” media player issue.

Having done more testing, I have started a new discussion based on my findings. Please follow this thread and confirm your own testing results if it applies to any of these scenarios:

  • reset files to “0” bytes

  • unsupported file type

  • cleaning up minor inconsistances on the drive


mike27oct wrote:

      You wrote>>>   as I generally keep my backups on that same drive.


Duplicate files on the same drive are not “back-ups” they are simply duplicate files.  Back-ups are only back-ups if they are on a separate drive. 


Thanks for the pro-tip, sport - but these are not copies of files that are already on the drive, they’re my files from other computers. They’re stored on this drive as I was under the impression that the WDTV box was largely a read-only device (save for the index/thumbnails that go in the .wd_tv directory).

mike27oct wrote:


Your are dissing the WDTV box unfairly.  The WDTV does not write to video files, audio files or other media files.  It writes to it’s own files only; the ones keeping a record of the library of files on the given drive.


If the WDTV box did not write to media files then the files that I copied onto it would not magically be reset to 0 byte file lengths when the box tries to access them. These files were complete, and were copied over fine - it was only when the WDTV box went to access them that they were set to 0 bytes. 

I have since been using the WDTV box as normal, and it has not deleted any other files. It was most definitely that particular file, and not my drive.

Your comment on piracy doesn’t seem to bear any relation to the conversation - as with your note on my backups, you make a lot of assumptions.

OK, I get your point about the backups being different than files on the given drive,  The comments were not so much directed to you, but to help anyone reading these comments, as there are folks who DO think that duplicate files on the same drive are “back-ups”.

The piracy comment was also not directed expressly to you, but to anyone reading the comments.  (I purposely did not accuse you of piracy.)   During the year-plus I have been reading these forums, there have been quite a few people who complain about some video they downloaded via Bit Torrent, etc. not playing on WDTV, and to anyone like that, my comments stand.  I request they do not waste our time asking the Community to help them with a file of questionable origin, integrity, quality, efficacy, etc.

Now, back on topic:    So, did this file that showed on WDTV as 0 bytes appear that way when you reconnected the drive to your PC and you took a look?  If so, and you knew it was not that way before; agree, something nefarious appeared to happen to that file; perhaps as you assert, caused by WDTV.   As a WDTV user, too, I hope that wasn’t the case and hope there is another explanation.

We have occasionally downloaded a music track from our eMusic service that contained all the track info and even loaded into iTunes, but was actually 0 bytes. (Of course, it could not play, and the track from eMusic was the defective one, and it carried  the defect over into iTunes.)  Re-downloading the file was the solution.

This discussion has been on a number of forums

One possible solution: http://forum.wdlxtv.com/viewtopic.php?f=31&t=4246

This fix seems to clear things up for me. I think the whole"0" byte issue could be avoided by never disconnecting your media and doing the transfers over the network.



I have not had a problem with it resetting files to 0. But did start have it start making me scan my drive everytime I hooked it up to the pc. I was using my passport 320 gig and thought maybe the drive was going bad so I bought a 1 tb passport. At first it seemed to work alright. Then it started doing it also. I was thinking it has something to do with turning the unit off with ejecting first (but its suppose to spin down when turning unit off. Or when turning off then pulling cable. If I leave unit on and never turn off then eject and plug into pc it seems alright. Otherwise when I hook to windows 7 64 bit pc it says drive is currupt and wants to scan it. I have only had this new passport for about 2 months now and even had to reformat it becuase Windows checkdisk whould hang and could not fix what wd tv live did to it.