WD LIve box resetting every 20-30 mins


I’m new to the forum, so please excuse any etiquette errors or just idiotic mistakes.

I bought a WD TV Live box last week from PC World in the UK. I got it home and set it up, and it immediately asked me if i wished to update the firmware to the latest version which i did. The version currently installed is now 1.06.04.

The box is cable linked to a Virgin fibre optic broadband router.

Everything was fine for the first hour or so, then whilst watching a film on Netflix the system reset itself, turning off, and slowly rebooting. I thought maybe it was a problem with Netflix as it’s a new service so i tried a film stored on a WD My Book Live. The same thing happened 30 mins into the film. I’ve since then tried iPlayer and the same thing happens too. It does it with everything basically, and it’s very very annoying.

I’ve tried a factory reset, and also a hard reset unplugging the whole lot and leaving it for 30 mins. It hasn’t helped. I guess it’s either a firmware problem or hardware overheating. What can i do to help this problem? If it’s not fixed then I’ll just return it as faulty, but I’ve bought a few WD products recently and would rather not.

I’m over the moon with the product if this could be sorted. Of course having all the rest of the TV catch-up services available would be amazing, but as it it’s brilliant. Or it would be if it stayed on for longer than 30 mins!

Please help!


Has anyone got any tips/soulutions for this? It’s driving me around the bend. 

Sounds like the best solution is to return it to PC World and get a new one as it looks like a hardware fault.

Mr friend, i have experienced this issue as have many other “SUPERDUB” users lol

the fix is easy, go into admin settings on superhub and turn of UPNP. :slight_smile: everything is fine. Or set it to 1440 minutes if you dont like to turn of UPNP.

So that is like a software bug then? Why has WD not fixed it?

Unless you are putting the blame on the Virgin Media Super  Hub?

Its a bug in superhub firmware. Its not WDTV problem.

I’ve tried changing router, and it still occurs so defintely a WD problem.

If its hardware I’ll return it, or if it’s software does anyone have suggestions?

I agree, it’s a WD problem.

Even if the SuperHub is sending “illegal” packets (which I’m not convinced that they are sending anything illegal) the WD should not crash or reboot as a result…

It’s a type of DoS flaw that should be easy to correct if the developers can find the “killer packet” and handle it correctly…

So do other people have the same problem? Should I exchange it? If I do will the same issue be there?

Thanks so much.

My TV Live suffered from a similar problem.  Setting nPnP of the Superhub to 1440 appears to have it fixed.

Thanks again

I replaced the hardware anyway. Also turned UPnP off. 

Everything connected to my home network is still working just fine. With UPnP turned off what should i look out for?