WD Live and Mavericks - Can't save to drive

I have the 3TB WD Live that has worked flawlessly as a media server to the TV for a few years now running off PC platform.  When I switched to Mac it continued to work the same - I could download video straight to My Book Live and stream wirelessley to my WD Media players.  It continued to work flawlessly after upgrading to Mavericks.

The problem started after i upgraded the firmware to the latest and the MAC version.  I can still access video music in MBL on MAC and on TV via WD media players but I cannot save downloads to the drive as I have always been able to.  IT says I dont have permission etc.  I have been able to fix temporaly by remounting the drive but it drops off (for saving only, drive is still visible & usable) again for saving download files “no permisson message”.  All the settings in the Dashboard are correct etc and no adjustment there seems necesary or even possible as the settings are correct.

This is an extremely frustrating problem and at the moment I am thinking of ditching my WD hardware and replacing with Time Capsule.  If anyone can suggest a solution that would be great as at the moment it seems this is just a ‘dumb’ hard drive that I cannot save downloads to.     

Hello Doublee,

 Try mapping the drive again and change the permissions to public to see what happens.

Check the follwoing link for more infomation.



Thanks for advice but I have remapped the drive a number of times and all the permissions have always been public.

These were the first steps and tried and checked.

Further to previous post should have added those steps did not solve the problem.

Support has suggested I back up the drive  and reset but the drive is working as I can stream movies to my WD Media Players and TV.

I cannot (or can’t think of how) I can back up the drive as I don’t have ‘permisison’ to transfer files or write to the drive.  So a reset of MBL probably (?) means I lose all my data as It can’t be backed up.