WD Green detected by BIOS but not by OS

Hello, I would like to ask for help. I have been fighting for one month since I bought an internal drive WD Green 1 TB. Bios detects it OS - Xp Prefessional SP3 - doesn’t. Disc Management doesn’t find it
I have a MB Asus P5KPL VM.
I have another WD 3200 AAKS with OS on. Before writing this post, I read many posts on this matter and using hints to fix the problem. For example downloading intel accelerator application accelerator or intel storage rapid technology are not compatible with the chipset I have.
I tried to switch cables but that is not the cause.
I thanks all of you in advance

Hello,

Have you tried on a different computer? Also try to run DLG on the drive to see if the issue has to do with the drive itself:

This is the DOS version:
http://download.wdc.com/dlg/dlgdiag_5_22.zip

This is the Windows version:
http://download.wdc.com/windlg/WinDlg_v1_29.zip

Thanks,
I downloaded the DOS version, as in Windows DLG doesn’t detect that drive, but I don’t know how to create a bootable CD. The WD manual talks about a ISO file, but as described in this thread has been removed
What happened to the Data Lifeguard ISO download?.

How can I run DLG for DOS having a CD rom?

Hello,
I have been able (not so easy for me) to run Dlg Diagnostic in the DOS version, as ArMak gently advised me. The test was Ok , with no errors or other issue.
So the last question is "Should I format that hard disk in the DOS or does my motherboard Asus P5KPL VM need any new driver or accelarator to let me use a 1 TB HD as I read somewhere for old MOBO?
Thanks

did you tried on another sata port?

did you install the sata drivers?

Hi, i highly doubt that you have any issue with he drivers, try to write zeroes with the DLG software, see if after doing this you are able to use the drive.

i would use a heath monitoring program like hard disk sentinel or cristal disk info to view the smart data

Yes, I tried all the orthers port.
No, I didn’t install sata drivers, but the HD with OS (WD sata 250 gb) has never had problems.
or the fact this new one is 1 TB and an old MOBO can have problem with it.
Anyway I couldn’t find drivers for XP in asus site.
I ll try Write Zeroes with DLG.

thanks

If I run Write Zeroes Master Boot Record will be deleted than I have to discover ho to create it.
DLG tested the HD and it sounded OK. In your opinion what can Write Zeroes fix?

thanks

all the user area will be 0000

write zeroes normaly is like receiving the hard drive from factory (brand new) without any data on it

My HD is brand new, never used, just bought. I don’t know anything about Master Boot Record.
What creates a Master Boot Record? What are its functions?

If you write zeros your drive will be erased. The easy way to create a boot record is installing windows or another OS distribution on the hard drive.

I think the main function of the master boot record is with special files tell the bios of the conputer to boot from that drive to the OS of your choice.

Maybe you are making confusion with the partition table instead of master boot record

I don’t need to install an OS system on that drive. I would like to put videos, photos, there. My question is : If I use Write Zeros i will delete everything even a master boot record if it is on the HD.
Than how could I create it again? I have never involved in this kind of matters, probably my question is a stupid one.

yes its a stupid question

write zeroes to the drive then quick format the drive to nfts and its done :slight_smile:

I run write zeros.
Another stupid question :smile:
How can I format the drive if OS doesn’t recognized it?

You can use disk management service on windows ( its there since windows xp i think). In the search bar write diskmgmt.msc and format the hard drive that says unalocated. dont forget to assign a letter

Or use easeus partition master free and do the same thing.

Thats a great software for free :slightly_smiling:
Best regards

And OS recognizes the drive if everything worked correctly after the write zeros. It just doesnt show up because it doesnt have any filesystem on it before formating

Ok thanks, but
As I wrote in the object HD is not recognized by OS. So Disk MGmt can’t see it and EPM will not.

How can I write on that HD ?:confused:

Exchange the sata port connected in computer; the sata cable and try another power cable from the psu.

If that doesnt solve your issue i would try on another computer to avoid sending a good hard drive and have motherboard issues.

If that doesnt solve your issue RMA the drive because its dead…

Hi Cesare, could you tell us a little bit about that HDD?

I can suggest you quite of things, but I know that Windows® XP SP3 has some problems with SATA drivers.

My first approach would be to try with another OS, for example, the latest Linux® Ubuntu, which you can first load it to a flash drive unit or DVD and then boot it from there using the Live CD (or USB) option when you boot it, so you don’t need a physical unit drive (HDD) to use it, but it will recognize any drive attached to the SATA ports on your motherboard, if the HDD is working well.

Link: http://www.ubuntu.com/download/desktop