WD Green 960GB missing in LinuxMint

WD Green 960GB missing in LinuxMint.

I bought it, installed it.
So I have a bootable 256GB NVMe, and a WD 960 GB alongside.
Works in W10, sub-divided into 4 parts. S,T,U and X drives.

Linux Mint installed on 256 GB NVMe after shrinking the C: by 85GB.

LM has Gparted installed and it does not register the existence of the drive.

So where to start please.

I suggest just using Windows as hybrid systems are too dodgy with some smaller distributions

use a virtual machine for Linux if you need it

Thanks, but I posted that using Linux Mint, and do not see any advantage in a virtual box option.

dual boot seems to be more troublesome

I have been dual triple etc booting for decades.

My problem is that the WD drive doesn’t show up.

Intel do drivers, AHCI is also possible.

I just don’t want to lose stuff unnecessarily.

So Will try a few things and come back.

So I tried DEBIAN LIVE and it does not register the existence of the drive either.

So there it is in Windows 10, but totally missing in Debian and Mint.

I suspect it is mis-representing itself, hence Mint misses it.

I am not sure what system you are running, but check your BIOS and make sure your storage is all set to AHCI and not RAID (Intel chipset will commonly have M.2 slots as RAID). Linux does not have the driver for running the M.2 slots in the RAID BIOS mode.

If that does not work, you might want to consider trying the WD Green in another port on the motherboard.


Apologies, I have made progress.

You are correct about the AHCI setting.

That borked W10, and it a few goes to get it corrected.

Then I could and did install LinuxMint and see the created partitions.


I will attempt to close this as solved.