WD Green 2TB shows up as IDE in Data LifeGuard

I have a Windows 7 64bit system with a Black 750GB as my main drive and a Green 2TB as my backup drive. In the Data LifeGuard Diagnostics software, my Black drive shows up as SATA, but my Green drive shows up as IDE. I don’t see anywhere in my bios to adjust this. Is there a way to change it to show up as SATA and if not does having it as an IDE drive affect performance?

WD20EARS Shows up as IDE

Sounds like it could be a system glitch try restarting the computer again.

Another questions Is that sata drive thats being misread a inside a enclosure?

I’ve restarted a few times today and it still shows up as IDE.

It’s not in an enclosure. Just inside my computer case installed in the drive bay.

It does sound like a Bios setting that needs to be changed. Have you tried contacting your Mother Board manufacturer to see if you can change settings for IDE to SATA?

I’m using the Asus P7P55D. I didn’t see any BIOS setting to modify it from IDE -> SATA. I also couldn’t find contact information for Asus so I tried posting on their forums.

I’ve found this number for Asus 1-812-282-ASUS(2787). They should be able to help you on changing the settings . 

I’m using an ASUS P8H67-V with an updated BIOS and I’m seing the same issue.

Did you find any info regarding this?

I personally wouldn’t be too concerned about this… the SATA Hitachi drive that came with this PC as OEM has always shown up as IDE and not SATA in DLG.  The drive’s worked fine for 5 years connected to the SATA port, regardless of what DLG calls it.