WD Gold 6TB problems with Mac Pro 5,1

#1

Hi there! I bought 2 WD Gold 6TB drives to upgrade the old drives in my Mac Pro (2010 model). The drives work perfectly, but whenever I reboot the computer, they won’t show up again, and are apparently not even detected as present in hardware (in Disk Utility). I always need to completely shut down the computer and turn it back on manually for them to reappear. I never had this problem before in this Mac or with any other kind of hard drives (I use other WD RE and Gold drives as well). It seems like a problem with this specific drive’s firmware or something like that. I got warranty replacements for the two drives already, but the new replacement drives still have the same problem. What should I do now?

#2

If the replacement drives are behaving the same but other WD Gold and WD RE drives do not then perhaps it would be best to contact WD Support about this for dedicated assistance. You can do so in the following link:

Try to provide as many details as possible related to the issue at hand and reference the replacement history.

#3

Thanks a lot for the information. I’ll create a case and try to be as helpful as possible to find this problem!

#4

It’s strange, I opened the case back then and didn’t seem to get a reply so far. Is this normal?

#5

Hi Usabell, did you find out the reason for that behavior?
I use 4 disks, 6TB each, in an Apple RAID-0 config.
Same behavior with our MacPro 5.1 - leading now to more and more files disappearing from the finder.
Around one million files are now gone - I wonder, if this could be fixed with a firmware update by WD…

greets, Hans

#6

Hi Hans, I contacted WD support again and now got an answer. They told me to provide some additional information, which I did. They told me it’s a complicated case and wanted to know even more, and I provided them with it too. Now I’m waiting for their next answer. It’s probably a bug in the firmware which can be fixed, but they need to find out what is causing it.

#7

I’m having the same problem with an 8TB WD Gold drive in a Mac Pro. WD support has so far been unhelpful (suggesting it was an energy saver issue).

I’m hesitant to use the drive at all, have you been using it, and have you found any issues with files missing like the above poster?

#8

Hi spacemoth, sorry for the late reply. I’ve been in contact with WD’s support about this issue for half a year now, and them being pretty unhelpful so far would be an understatement. They’re basically suggesting that it is a problem caused by Apple and that I need to contact Apple to resolve it, but this computer is out of their warranty, so there’s nothing Apple will do about it. Then WD support always tried to twist it so it isn’t a general problem with these drives, but a specific problem to my setup. They keep assuming things I never said, like it’s about a MacBook Pro (while I always wrote it’s a Mac Pro 5,1), telling me those drives are not made for notebooks. Today I got another one of these support failure gems, they assumed I never connected the drive directly to the internal ports of my Mac Pro (which I said from the get go). This is taking longer and longer, we’re running in circles and nothing gets solved at this rate. I’m starting to get bummed out because time between their answers is very long too, and then always some wrong information makes them believe it’s not them, which is not helping their cause. Let’s see how long they’ll play this game, I’ll soon switch to another brand of HDD manufacturers, problem solved.

Also, no missing files on my side of things here, just missing drive after a reboot (need to shut down and do a cold start to make it show up again). Also only happens when booting into Mac OS (no matter what version). Booting in Windows (BootCamp) never causes this problem… I guess the problem Hans had was because he used the faulty drives in a raid configuration, which can of course lead to much worse things. But yeah, I don’t really trust these drives…

#9

There are a couple of things you need to consider here:

  1. You are using enterprise drives in a desktop situation. Unless you’re using them in a RAID format that’s not the best use case for the drive. Also, I hope you’re not mixing an RE with a Gold in that RAID. Also, does the RAID chip support 6TB, 4K drives?
  2. You’re using 6 TB drives in an old computer. Are you sure that there isn’t a drive size limitation on that Mac? After all, 2 TB drives had barely come out around that time. That would be a BIOS, or whatever Mac uses for BIOS, issue.
  3. I know this might sound bad, but if the drives check out to be fine when tested, that’s as far as we will go with it. You need to contact Apple about any drive compatibility issues.
  4. Finally, as a drive compatibility issue, if they are incompatible - which is how it’s looking, a firmware update wouldn’t fix it anyway. Incompatibility, by definition, means that there is a design difference that prevents one device from working with another. It could be that the drives are 4K drives or larger than 2TB. Or, any number of other significant differences.
#10

Thanks for your reply, Bill_S. I understand that you have your doubts like the other members of WD support staff I already have been in contact with. However, we really face a very strange problem here, let me elaborate a bit on your points.

  1. I am not using a RAID, and I mainly choose RE (and now Gold as a successor of RE) because I want the most reliable drives available, with maximum stability, longevity and performance. I’m trying to use the drive to stream massive amounts of audio samples in a professional Mac workstation, and I’ve seen it mentioned that workstations are one of the uses for WD Gold drives. If that is wrong information, please tell me what other drives would be more suitable for my situation.

  2. To my understanding, if there were a size limitation in the hardware, the drive would not work at all or only be formatable to 4TB (or 2TB, whatever the size limit is) capacity. This is not the case here. The full 6TB of the drives is usable. I can also assure you that this is not a limitation because this Mac is an “old” computer. I have an older Mac Pro 3,1 (from 2008) which can use these drives without any problems, with full capacity. The problem only appears when rebooting the computer, and the workaround is to just shut the computer down and boot it from that state, which 100% works for now, but is annoying. Are you trying to imply that Serial ATA standards have changed and for the newer drives there is a need to get a newer computer/motherboard? I never heard of this. They should then call it something else like with the IDE to Serial ATA transition, and make different connectors so you cannot mix and match them anymore if that was the case.

  3. The drives definitely check out fine and work perfectly on both Mac Pro 3,1 from 2008 and Mac Pro 5,1 from 2012. It’s just that in the Mac Pro 5,1 whenever I restart the computer the drive completely vanishes until I shut down the computer completely. But there’s no loss of data or other problems. Still this is a serious problem, as the Mac Pro 5,1 is still the ultimate modular Mac workstation computer. It might be old but is still sued by many professionals because of a lack of a proper replacement by Apple. Of course the fault is also partly caused by Apple, but that’s only part of the problem. Other manufacturer’s 6 or 8TB drives work without these issues. I might have to change to a different drive manufacturer if you’re unwilling to fix this issue (and so have lots of professionals I work with).

  4. There really shouldn’t be any incompatibility, that’s what standards like Serial ATA are for, right? I find it really strange that this issue hasn’t been resolved already after more than half a year now and lots of different people reporting the same issue all over the internet. Instead they are not taken seriously by WD staff, which doesn’t really help the situation. We are not crazy, these problems are real and affect all of these drives in combination with this model of Mac Pro. I know it will be hard to pinpoint the cause, but if all future WD drives will have this problem, I need to get a different brand of drives to continue working without problems. For now my workaround is to use these drives in an external eSATA enclosure, and they work without problems from there, but that’s not what I intended. I wanted to fill up the internal bays of this Mac Pro with WD Gold drives.

#11

You are actually kind of proving my point. The drives work fine everywhere but in the Mac Pro 5.1. That would be the primary way you show that there is an incompatibility issue. This has nothing to do with SATA standards. Something about the Mac Pro isn’t liking the use of the WD Gold drives.

Besides, when I look up the Mac Pro (Mid 2010) specifications, it shows the max storage capacity being 1-2TB per SATA connection. You get up to 8TBs if you put 2TB drives in all 4 SATA ports. So, you shouldn’t even be using a 6TB drive in that Mac Pro. It’s not designed for it. And, it doesn’t matter whether the 6TB drive works off and on, it’s not supported on your computer even by Apple.

https://support.apple.com/kb/sp589?locale=en_US

#12

The “limit” Apple specificated is just a theoretical one though, as they didn’t have experience with larger capacities at this time. It’s been proven that there is not really a limit set in hardware, or else the drives would not show up as their actual size like I already mentioned. You can see more information about this here:

Also, what is your explanation for the older Mac Pro 3,1 from 2008 having no compatibility issues with WD Gold drives?
Or other brands of HDDs working without problems in a Mac Pro 5,1 from 2012, even at sizes larger than 2TB?

Also, all my 4TB WD RE drives are working perfectly fine and don’t show these problems at all, even though they are apparently beyond the specification for this Mac, too. What is your explanation for this?

I can only repeat myself, this is not a problem caused by some storage space limitation of this or any other Mac Pro, they have no limit like that. All the space of the hard drives is accessible. The drives work and can store data and work just fine, they just have this problem during boot time. There is no cap at all. All the RE drives I have work perfectly, even larger ones that exceed this “limit”. So it’s only a problem with recent WD drives like Gold and newer Red drives larger than 4TB (I didn’t test 5TB drives), so by looking at the differences between these drives’ controllers it would be possible to solve this problem, if you would actually be interested in this.

I already contacted Apple about this issue, and they are not willing to be of any assistance. Now I contacted WD and they also are not willing to be of any assistance. Basically I’m told I need to buy a new computer, which is ridiculous, as there is no real alternative on the market right now, and I don’t see a reason to upgrade to an expensive new computer just because of some random incompatibility with some HDD firmware or whatever it is causes this.

I tried to be as helpful as possible and invested quite some time trying to get my point across over the last half year. I’m not some random average consumer who accidentally bought an enterprise drive and doesn’t know how this is supposed to work, I chose this drive because I was very, very satisfied with the WD RE line of HDDs and would like to continue using them, but they were replaced with the problematic Gold drives now, and with the lack of support given from all sides I guess I just have to give up now and settle for some lesser drives, because this problem is not resolvable…

#13

To anyone with these problems who might be following this discussion, It might be worth noting that other people seem to have no problems with 6TB WD Black drives in this situation. Mac Pro 4,1 also seems to be affected, and it seems it also has to do with the version number of the Mac OS used. Mac OS 10.6 (Snow Leopard) doesn’t have the problem, while version 10.7 (Lion) or later does have the problem. Here are more details:

https://arstechnica.com/civis/viewtopic.php?f=19&t=1300231

I might try an 8TB WD Black drive soon and report back.

Still wondering why a WD Red 4TB drive works while a WD Red 8TB drive won’t work. Was anything about the TLER changed in later WD Red drives? I’m just asking to find out which drives might work and which ones won’t before I buy them.

#14

Hi Usabel,

Purely for my own personal interest, which version of MAC OS are you using and what response do you get from an “About This Mac / System Report / SATA - SATA Express” query? Does the geometry look OK for instance? When you open the “Disk Utility” program, what does OS X say about the disk you have installed? What information is displayed about this disk under the “Info” tab? What do the OS X logs say about the systems behaviour?

Just a shot in the dark here, but the MAC OS X file system is “Journaled” and even though it will be divided into volumes, 6TB is still an awful lot of real-estate for a Core Duo processor to be overseeing, especially when it’s busy with so many other tasks, making journaling very much a background process. I’m just wondering whether the journaling system has time to write all of the changes before system commands a reboot, thereby leaving journal entries unwritten and the disc compromised? A hard reboot would clear the unwritten journal information to the disc, ‘et voila!’

I suspect that trawling through the logs might reveal something interesting and I believe there are utilities you can download now to aid searching for specific issues.

Anyway, luck with that!

Best Regards,

Mango Biche

#15

Hi Mango_Biche, thanks for your concern with our situation. I compiled a lot of information in a document, which you can get here: http://daniellippert.ch/private/WD_Problems.pdf

I hope this will answer a few of your questions about this very specific issue. I see there are still some misunderstandings regarding this, so let me answer some of your questions directly:

  1. I’m using a triple boot machine running Mac OS X 10.8.5, Mac OS X 10.11.6, and Windows 8.1. The problem only appears in Mac OS (no matter what version). When I restart the computer and boot into Windows, all drives show up just fine all the time.

  2. Disk Utility doesn’t show the drives at all. This means there isn’t a “logical” failure of the drive’s data structure, but a hardware problem that makes the computer not “see” the drive at all after a reboot. To be honest, it’s just the same as if the drive wasn’t physically connected at all. Only after a full power down and boot from that state the drive shows itself again and communicated with the computer again. Again, without any logical damage to any data on it, or problems with its journals. The journals are written on power down/reboot before the computer starts up, and that process completes fine without any problems. Also, your idea of the journal data being written on shutdown does not make sense, since the computer would not have physical access to the drive if it doesn’t show up anymore. So there can’t be anything write to it to make it show up next time. If the journal would be messed up and the drive would be damaged by this, it would still show up in Disk Utility at least.

  3. The Mac Pro is not a Core Duo architecture at all. It’s a 12-core system, with dual 6-core Xeon processors, and should pack enough power to have no issues for years to come, and that’s also why I won’t replace it anytime soon, even if Bill_S suggested so.

  4. From what I read, this problem has to do with the TLER settings of the drive. Is there maybe a way to change these settings to make the drives behave like the older versions that just worked? Like WD Red 4TB or WD RE 4 TB drives? It seems WD made some changes to these drives that cause these problems with this Mac Pro model.

#16

I’ve got another update on this issue after contacting WD support again for a lengthy time. It seems to boil down to this:

The problem seems to be indeed a TLER-induced problem with these newer drives. Since these newer drives work differently from older drives where TLER could be changed with a tool provided by WD, there is no way it can be fixed in the hard drive itself, which is sadly the final answer to this.

So all that remains now is to try changing things in the boot sequence of the Mac that leaves a bit more time for spin-up of the HDD. I’m not an expert when it comes to this, but maybe someone with some experience with under the hood Mac OS variables and modifying them can chime in here and help out. If that works, I’ll gladly wait a few seconds every time I reboot my Mac. Better than having to shut it down all the time.

#17

just tried a 6TB WD “WESTERN DIGITAL Blue WD60EZRZ 6TB 3.5” Internal Hard Drive Sata 5400Rpm 64Mb”

I setup using a USB dock , fine , put it in the bay 3 sata 2 , and reboot , nothing . drive not seen in hardware in DU .

I have sata 6G pcie cards , so will try in a moment with the 6G connection . and report , back.

Note: Was using 4TB WD drives without issue. Green and Purple 4TB was working fine in any bay on the x4 sata2 bays or even the spare cd drive bay , “Lower" etc.

#18

Sure enough , the 6tb drive shows up as expected on the 6g pcie interface…
both cold and warm boot fine…

Switched back to the bay 3 , power lead out cold boot , and nothing . absolutely nothing . does not show in DU…

Result 6TB drives are a no go in MacPro 4,1 5,1 bays .

#19

What a funny coincidence. The moment this thread comes back to life I found out that WD actually fixed this problem with their latest series of drives. I just bought a brand new WD Red 6.0TB drive for my NAS, and it was the newest model with the 256MB cache (WD60EFAX). I put it into my Mac Pro 5,1 tower to format it with zero data, to get rid of the bad blocks. After it was done, I rebooted and it was still there. Seems like the latest series of WD drives doesn’t have this problem anymore. I can only say that for the latest Red 6.0TB drives so far, but I think all drives of that series should “act” the same. If anyone could try this out and confirm with the newest 8, 10 and 12TB drives, that would be sweet.

#20

converting to 6g sas etc is a work around too.

however, for me this is a begone era, just setup and transferring with the bigger Backup drives to i9 hackintosh build. why apple never just revamped the mobo i have no idea.

farewell , 5,1 , dual x5690 it was nice knowing you.