WD Go certificate error using Windows 7 Ultimate and IE 11 or Chrome

Because port 443 is already ported by another application that I cannot changed I had to change the ports for MBL Remote Access to use 8080 and 8443.  When I attempted to connect to my MBL for the first time remotely Java prompted my for certificate info because the *.devicename.wdc.com was not certified.  Because I have several registered users that are spread across the states the solution of creating a self signed certificate as discussed in one of the other thread is not an option.  Why is a self signed certificate required to use SSL connection, why didn’t WDC consider this as an issue using port forwarding? The documentation is lacking information on this subject and it seem to me from the other threads that is problem is not being considered an issue by WDC.  wd2go on my android phone and tablet works but having it work on the PC is a requirement since we generate a lot of pictures during our traveling and need to post them to the cloud so we can have them at the office when we return. 

Also, if the certificate problem gets resolved will that also fix the 1244 error on all of our shares.  

Uh, what?  Certificates have no bearing on port forwarding, so I’m not sure what your question is.

Ok, maybe they do not and I only have 1 problem, the certificate problem and the 1244 error attempting to open a share from wd 2go.  How can it be resolved and how do I get the other registered users working when I open up access to them?  I reviewed the manual and I do not get the popup window described on page 113 but I do get a different one that asks if I want to run the application.  I get this after I select my device and enter the network password. 

Look at section 5 of this document:


It may explain it.

(Yes, this is with respect to MS IIS, but it’s more about WebDAV, which WD 2go also uses.)

I replaced my device number with [nnnnnn], or blanked it out, in the URL. 

I followed the in the steps outlined in the document and added a AuthForwardServerList entry in the registry on the remove machine and used  https://mybooklive.device[nnnnnn].wd2go.com as the URL.  I did not put my port number in the URL because it said not to use port numbers, my port is 4883.  When I go to the web site I still get the 1244 error message.

I also tried to use net use in a DOS window to map the dirve directly and still got the 1244 error message:

net use * https://mybooklive.device[nnnnnn].wd2go.com:8443 password /USER:registered_email_address /PERSISTENT:YES

System error 1244 has occurred.

The operation being requested was not performed because the user has not been authenticated.

I tried net use with and without the port and received the same results. 

Also, What is this prompt for?  It is not documented and I really do not want to give out the network passwork to everyone. 

This might be a better screen shot.

THAT is the authentication screen. 

You MUST provide a password there (for “mike”, in this case).

Can you let me know where the documentation on all info that must be given to registered users to access the shares they have access to.  In my case I have 3 shares and each one has a different share password.  If the share passwords are required then why am I only prompted for 1 network drive password?

mefrazier wrote:

If the share passwords are required then why am I only prompted for 1 network drive password?

“Shares” do not have passwords.   USERS have passwords.

It’s asking for the password for the USER assigned.

Once that password is given, then the user will see all shares to which they are allowed.


I have read the manual many times to no avail.

Here is my first screen.

I enter my remote userid and password that is associated with the shares I have access to.  Here is the second as documented.

When I select the device I get this. 

Note, I erased the device number from the url.  I select ‘Proceed anyway’ and the get this.

I enter the ‘Network password’ and then I get this screen


I click the ‘I accept’ checkbox and then Run and the shares page and when I click on any share I get:

I have also done what was suggest earlier today by changing the registry.  

I changed ports 443 and 80 to 8443 and 8080 in the Remote Access tab of the Settings page because they are already used by an application that I cannot change.  I have opened the ports on my router.  Here is the Remote Access tab

What can I do to resolve this.