WD glowing yellow and reset button not working

Hello, I’ve been trying for 5 days to try and connect to my WD mycloud. I’ve tried 4 seconds reset and 40 seconds reset button, but no luck. The ethernet cable is blinking green on the back on right side. but is glowing yellow on the front. as if it has no internet. i’ve also tried to connect the internet stright into it, but still same issue. I don’t know what to do.

Who is your internet/broadband provider? If AT&T there is a known problem with some AT&T routers. The solution is to put a second router, or a switch/hub in between the AT&T router and the My Cloud.

What happens if you connect the My Cloud directly to a computer’s Ethernet port?

Glowing solid yellow? That’s not a valid indicator for any of the Mycloud single drive units or firmware.

Is this a new device, or an old or seconhand device that has worked before?
What is the model number (on the plate on the base)?

If you can’t connect via a router, or direct to a PC, it suggests a problem with the network port or cable (though I note your flashing green).

I’m in norway, so my ISP is called “Altibox” and my second router is a asus RT-AC66U

Not sure if this is the old or new.

There should be a pair of numbers at the end: 00 or 01 (Gen1/Gen2).

When I said ‘new’, I meant is it being used for the first time?

No i first got mine in 2014 but then it broke down for some reason and i got a new one, in 2015 i think.
And now it randomly stopped working 5 days ago.
It was working fine before that.
Also my device has - 00 on it.

Did anything happen to your network five days ago? Like a power loss or routers being power cycled, or router firmware being updated? Have you tried replacing the Ethernet cable to the My Cloud? Tried different ports on the router the My Cloud is connected too?

Not sure if it’s the auto update, i can try and downgrade the asus router, to see if the update broke the ethernet connections.
I have tried another ethernet cable, but all of them is 5c that i have not 6 that the new myclouds have.

Just took the router back to an old version, didn’t seem to have any effect.
It says there’s no connection to any local device.
The cable is connected localy to the router.
Can’t be the routers fault, because it was last updated

I’m beginning to see a pattern to the recent threads:

Given that WD reported having remote access problems recently, I wonder if their problem has not yet been resolved properly.

Could be, because it¨s not the router, as that’s not been changed for over a month, and i’ve only lost connection 6 days ago.
The WD does have auto update on, idk if WD got a update the last 10 days.

My understanding was that it was an issue with their servers, not the client software (MyClouds). Not that WD gave much detail about what the symptoms of the problem were…

This was the thread I was thinking about:

I got this E-mail today, not that it helped though.

-	Please retry a 40-second system reset: A System Restore from the device does not cause data loss, but all private shares become public.

Follow very well the instructions as it is a very specific type of reset:

Unplug the power cable, press the reset button with a paper clip, LEAVING IT pressed, reconnect the cable, WITHOUT REMOVING the paper clip. Hold the Reset button for forty (40) seconds.

After that, you must wait for the frontal led to become solid blue.

When you (re)access the Dashboard, you will need to choose the language, and insert your e-mail as well as other data. If it does not ask you that, then the reset is not well performed, and you must retry.

-	What is the status now on the Led light?

According to the manual, a Yellow Blinking light on the frontal led can mean: 

• Disk thermal warning threshold
exceeded (under or over temp)
• Network cable not inserted
( http://support.wdc.com/product.aspx?ID=904&lang=en )

Is the issue solved?

If not, please try with different Ethernet cable, to connect on the back of the device, and on different Ethernet Port on Router. Also be sure to reboot the Router.

Also, connect the PC with Ethernet cable to Router – it is the optimal configuration.

While waiting for your reply, I wish you a pleasant day.



Good that they read what you’ve already done, isn’t it…?

And report what the manual says (incompletely)… (I’m assuming your solid yellow really is solid yellow, and not solid white).

The yellow led is caused by one of the following three conditions. LED_EV_NETWORK=5,LED_EV_THERMO=8,LED_EV_DEGRADED_MIR=12. The degraded_mir has to do with the raid. The thermo is only a warning. The other two colors can be a warning or an error. In the /sys/class/leds/system_led directory are files that contain the the color and blink info. In /tmp directory are four files called led_cur_ev,led_cur_st,led_err_ev, led_err_st. They contain the reason for the led color.


I’ve got no way to acess the WD as of right now.
It doesn’t let connect on my laptop or any other laptops in the house, i’ve tried on 3 laptops.

You can try arp -a on a windows system. This will list all known mac addresses and there IP address. Look for your My Cloud mac address. Also you could try macaddressview from nirsoft.
This way you can see if the IP address has changed. On my system the bottom led on the back is solid green and the top led is blinking green.


That command only listed my printer and the rest of my devices, not the WD.
Also my WD doesn’t light on the bottom doesn’t light, it lighted on the start but not now.
The top light on the back is blinking green.

When I pull the network cable from My Cloud device both leds go out. When I plug the cable back into the device the bottom led lights solid. Then the top led starts to blink. The bottom led says that you have no link. The top led says that there is activity.