WD firmware updater doesn't work on My Book Studio 1.5TB

Dear all:

Today I tried to update my device’s firmware from v1.004 to v1.012, but the activity bar on updater just running again and again, even though device already automatic entered sleep mode@@. When I unplugged device and tried it  again, updater always shows: “Firmware update failed on specified device.”

Does anyone have solution? I update firmware because I want to hide Virtual CD from my computer…><

Type: My Book Studio 1.5TB (with E-Paper Display)


Firmware ver: v1.004

OS: Windows 7 64bit with SP1 on a Fujitsu Laptop

CPU: i5-2520  RAM: 4GB x2  Display: Intel HD3000

HDD: Intel SSD 520 Series 120GB

Try doing the universal firmware updater


Make sure your Adobe Flash and netframework 3.5 are up to date. If the drive is working OK I wouldn’t bother with the update. I’ve got an older My Book drive and I simply went into device manager and disabled the virtual CD there.


Dear all:

I had solved this problem by accident @@

I ran the WD updater on a Windows XP 32-bit system,

suprisingly there is no infinite loop, no error message and everything works fine.

Maybe some 64-bit bugs still alive in the updater I guess > <

Anyway, thanks for your reading and reply~^^