WD Firmware archives?


Still working on trying to get my Studio Edition II from firmware 1007 to 1015. Still haven’t heard anything from support and we have a 3 day weekend here, so I’d like to get this backup thing settled so I can finally reimage my system.

Anyway, I was just trying to see if anybody knew where and if we could get “old” firmware versions. Just wondering if my upgrade problem is not resulting from jumping 8 revisions… so, trying to find firmware(s) for Studio Edition 1TB between 1007 and 1015. Maybe by doing more incremental firmware upgrade, I’ll have better luck.




I have been trying to upgrade my Studio Edition II to the “latest” firmware 1.015 with no luck. I have tried on multiple machines and all of them report “upgrade failed. try again later”. I tried on Win 7 (x64) and got the “error loading generic library”, so I tried using a VMWare workstation running Windows XP 32 bits, no luck there. I finally tracked down a laptop with Windows XP and tried to upgrade. Same ugly message.

P/N: WD10000H2Q-00


current FW: 1007

It is a “1TB” model. I wanted to upgrade the drives to 1.5TB (so 3TB total) but without a new firmware, I am stuck to 2TB total (1TB in RAID 1).

I know many people have reported problems with firmware upgrades, but I have not been able to find a fix for this issue.



Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


Thanks for the info.

I have already contacted support about this. I was hoping the community would be more responsive than support.

So far, in 2 email exchanges, support told me to:

  1. follow the “special instructions”… they just give me the link to the firmware update page. Like I had not already followed those a dozen time
  2. run the diags with lifeguard utility. Again, like I had not already done that.

So, if anybody still has ideas, I am open to suggestions.



PS: If you are a moderator and want to remove this thread as a duplicate of the one I also started in the My Book section, go ahead.

Just so you know there is a procedure to update the firmware… It involves turning off the antivirus while updating fw.  it is also advised to unplug any other devices on USB (if you are updating via USB which I did).  The Download page has further instructions on on things to do like uninstall the DL manager etc so on and so forth…This is the page for my MYBOOK home edition 320 GB External  Simply enter the correct order number from the box 's UPC label in the search field at the support site. —>>  http://support.wdc.com/product/download.asp?groupid=111&sid=99&lang=en

Hope this help any others with problems