WD Firmware 4.00.00-607 does not resolve issue of device losing connection to the network!

 Please Wd!

You promised that WD My Cloud Firmware Release 4.00.00-607

would resolve issue of device losing connection to the network


My WD Cloud has Firmware Release 4.00.00-607 but it loses connection to the network on daily basis!

Please, how will you solve this problem?

This kind of hassle and stress of losing contact to the data

is not why I bought this buy this expensive 4TT Wd Cloud!

I bought it while I believed in Wd advertising that Wd Cloud would be useful and give efficiency to one’s working environment.

When will we get the promised firmware release which

truly resolves the issue of device losing connection to the network?

The current situation with this firmware does no good for anyone,

neither for Wd’s businessess or your soon to be ex-customers!

Thank you Wd for your response to your customers!

I had the same problem as have many others that v4 firmware version is absolute garbage !!.

Downgrade your firmware to version 3 and turn off auto update if you have it switched on and all your problems will go away.

WD really need to fix this with an updated firmware that does not cause all the problems of dropped network connection sooooo slooooow! performance. etc etc etc …

Search on this forum the instructions to downgrade are on here and it’s really easy to do!

It must be cos I managed it and now all is working fine! 


Thank you for your comment! Sad to hear that you have had hard times earlier as well!

Please have you some idea where to find that earlier version?

And what version number the last properly working version for Win 7 has been?

I tried to find from here


But for some reason am unable to find any other version but the newest…?

In case someone has a link to tell, would appreciate it a lot! :slight_smile:

Thank you!

Your question is the same as mine.  I had found an earlier firmware after a search, but it will not install, so it may not be a proper version.  My question is down the list under my RoyFC name.

As of right now, I followed a suggestion on another thread and turned off the media settings under “Media” in the Dashboard.  So far my device has not disconnected, but it has only been a couple days.  What it does do, however, is often show 0% Used and “Unknown” for temperature under Quickview.  I can live with that if it does not disconnect again.

If you use your Cloud as a media server, though, then the above idea is not an option for you.  

For me, extending the DHCP lease time helped.  I extended it to 365 days.

Would you Please tell where to do that DHCP change?
Tried to find from Wd dashboard but did not succeed

Thank You!

that would be a router setting

setting a static IP is a better idea in my opinion

The WD Firmware 4.00.00-607 has bascially made my WD My Cloud not usable. That firmware has been out nearly 2 months with the Internet littered with complaints about it. Why hasn’t WD issued a fix?