WD External HD Wont Come On :o(

Just watched my new WD TV HD Media player with my fairly external hard drive and just fell in love with how great everything worked! This was last night.

Today, my WD hard drive will not come on. I think it has something to do with the power source, because if I wiggle the cord just right the lights will flash like it is going to come on. If the cord stays in the right position, the faint whirring inside will start, but that is as far as it gets. I tried it hooked up to my lap top and also back as part of the media player.

I am really hoping there are some suggestions out there for me, because I spent way too much on this external drive and have used it very, very little for it to not be working. Any help is very much appreciated!!

P.S. It is the MyBook Essential Edition 2.0

Did you try with another USB cable?
Is the power adapter from the external drive connected straight to the wall?

SInce you said you need to wiggle the cable then you should exchange the cable for another one… let me if that works…

Hey, I have the same problem… I have a WD my book Essential…

Contacted customer service about it and after a few rather lame suggestions of what I should do 4 troubleshooting (eg. change USB cable -DUH!) They came up with this:

_If the hard drive or data is no longer accessible, and all trouble-shooting solutions have been completed, it is unlikely data can be recovered without a professional data recovery service.

I apologize for the inconvenience, Western Digital does not have any in-house data recovery service, nor do we cover the costs to have the data recovered from your drive. We recommend using one of our data recovery partners._

To me it seems that the bug is in the Power supply which is simply related to a shoddy connection of the power chord with the hard drive ( the connection with the casing seems rather flimsy)

What really annoys me that WD does not seem to take responsibility for poor quality of the product which I think should fall under guarantee since I haven’t done anything wrong with it…