WD external HD will not mount on any mac

It was working fine a few weeks ago and today nothing!

I tried it with various plugs, with firewire cord, USB cord and nothing. The light comes on when I unplug it and plug it back and it looks like it is trying to mount but then it goes black. I re-booted it a few times. Nothing. All the other HD I have work fine. But this one is not mounting at all. I have no idea what model it is??? It has a long light in the front, two firewire ports in the back and a USB one as well as more others? Had it for over a year I think. Is there any mounting software out there? Are other companies make any? I need to get in there and it’s very upsetting that I can’t mount it.

Running 10.5.8 on G5

Please help.


Hi, did you tried opening the disk utility to see if it is recognized there?


Thanks for the reply…

YES, I did run both Disk Utility and Warrior and nothing…the light is flashing up and down but it never mounts.

I ran it for a long time and nothing. Tried different connections, nothing. I turn if off and start it again…the lights come on, it sounds like it wants to mount but just gets stuck…not sure what to do next? If it comes on then I can try to recover the data but it just does not want to mount. All my other HD work fine. So I don’t think it’s the mac…


drive spins up?


I’m fight tis problem too, and found something.

If you bought a pc pre-formatted my book you could be in deep s**t.

The factory is deployed a partition on the hd  approx 231 MB it contains (external firmware, and so on)

(i dont know yet what is the purpose of this partition, im in the middle of investigating)

But i supecting few things.

If you plug this external drive in a mac and if it’s reconize it you should start disk utility,(or the system offer you to initialize this disc)

The disk util see the logically possible usable area wich is not equal to the real usable free space because of the 231 MB partition, (my macs didn’t see this partition)

Regarding the problem when the mac can’t see this partition i assume the disk util try to declare the new partition owerlapped on the 231mb factory partition. ( i tried to delete it but no sucess until this time) and this is causing a logical problem for the disk utility.

I tried several tools like: win disk manager, in win7, and 8 beta. (actually the win8 can see the pre made part but not able to delete it, but the left over area is possible to use on)

I tried several linux edition, mandriva, suse, ubuntu, theese are capable to make HFS+ partition but cant see the real free space of the disk. So this way is useless for me.

I tried acronis true image boot cd and i saw there is a “phantom” partition but this tool not able to partitioning (not made for it) the leftover space.

I will try to use the Acronis disk director and will see if any result will be.

I’ll keep posted the investigation.