WD External Hard drive not recognized in my computer


Who do you thank and what for? Obviously you succeeded in getting the WD back on your computer? How?

Until now I only succeeded in getting an icon on my toolbar, which, when I open it, the computer recognizes as “WD 3 Externa USB Device”. But I don’t have any contact and I cannot find this device elsewhere on my computer.

Heldijk wrote:

Hey! Where can I find such a repair centre in Holland? I have a WD My Book Pro with the same problem. I have thousands of photo’s on it, only partly backuped on disks. For a year or so I didn’t have any problems. Than the misery begun: my computer (with Vista) did not recognize My Book now and than. It worked to pull out the cables and restart the computer. Recently it stopted recognizing it at all. If I had only read this and other sites with complaints about WD My Book before, I would have made a backup right away, when it still worked.

I think WD should  warn people for this misery in the manual and on their site. A ‘sorry’ afterwards in the forum doesn’t help people.

Did it stop recognizing the drive when your pc went to sleep?  Also, if you were pulling the USB cable out, and sometime before that you had been copy data over to the drive, it’s entirely possible that the drive partition got corrupted.  Can you see the drive in Disk Management?

1 Like

Thanks for your answer. I usually don’t allow my computer to sleep: it’s on or off. The problem only appeared with the starting-up of the computer. Then it didn’t recognize the WD. After pulling out the cables and restarting the computer, the problem was over, although I had to do this procedure sometimes more than once. Now I don’t get any contact at all anymore, this “WD 3 External USB Device” is still in my Config Sys-disk stations . I think this must be the one, for when I  put the cables in when the computer is on, the icon for safely removing  appeares on the task bar and describes it with that name and the addition “device for mass storage”. So it can’t miss. But what to do next? I still have some hope…

By the way, I tried to reinstall the setup with the software disk, but it didn’t work. 

I didn’t try any recovery programm yet.

same dam thing happened with me 100% on my labtop,and i think it is a million of users also,well it is very shameful as a giant and famous company named WD to release an item in the world market and it is not probaply well tested ,anyway they know the solution guys but they dont want to tell us ,concerning this exact recognition problem ,i believe the only way to solve is to remove the cover case and try to remove the green ship and then to make hard recovery (transfer the disk to another working case),or try to connect in a direct sata to micro B  converter ,in case the firewire matter doesnt work. 

i wish any body professional can help      or try email here  mrblack_2006@hotmail.com     

I’ve had the same problem with my WD 500 Gb external hard drive, my laptop just didn’t recognize or detect the drive one day all of a sudden, I’ve tried on diferent pc’s but I get the same result,  but when I tried hooking it up to my friends macbook then it was detected and I had access to the data!!! Can someone tell me why this is happening and how I can get my laptop to detect the drive again???

I have not tried my macbook, because someone has written that his macbook crashed while trying tot connect his WD to it. Maybe I have to sacrifice my macbook for this experiment. I want my pictures back!

If I were you, I would backup my data right away from the WD via the macbook and throw that WD away. And not buy a new WD external before they can make proper ones.

elgato wrote:

I’ve had the same problem with my WD 500 Gb external hard drive, my laptop just didn’t recognize or detect the drive one day all of a sudden, I’ve tried on diferent pc’s but I get the same result,  but when I tried hooking it up to my friends macbook then it was detected and I had access to the data!!! Can someone tell me why this is happening and how I can get my laptop to detect the drive again???

Are you moving the drive around on your computers, or is it plugged into the same power strip?  If so, you may not be getting enough power.  Plug it into the wall and see if it works then.

Hey everyone I am not going to lie I don’t know a great deal about computers. However it seems I have had the same problem as everyone else. I bought a 160 GB WD and plug it into my computer and it did pick it up for about five minutes, then it wouldn’t just like everyone else’s. However near by was my micro USB cord for my nokia phone, I plugged it in and it worked straight away and continued to work until I lost the cord. So I have tried using the original cord again that came with the product and it does not work again. So I am looking a purchasing another micro USB cord and I post on here again if it works.


I have this same problem all i can say is never again will i buy Wester Digital… had a internal hdd that was WD it died now this Hdd after 3 months of not much use only works when it wants to what a peice of junk… how are they even allowed to sell such a malfunctioning peice of [deleted]… Never Again!!!

Hi Everyone just an update, i bought a new micro USB cord and my computer has picked up the hardrive again , with everything still there, just got it from **bleep** Smiths, cost about $20… Hope it all works for you too… [deleted] cheers

hey I did the same as you mentioned and it worked for me. Thanks a lot …

but it isn’t the permanent solution so already contacted the Support team for replacement of hdd 500 gb


i have a western digital external hard drive of 500gb …

suddenly i got a problem with it… it is not showing in my computer but showing in device manager …

i tried in disk management but its telling " the media is write protected"

YA in the disk management the drive is showing but there is no drive letter , when i try to assign it , there is a error msg come " the Media is write protected "…
and able to do any thing bec of that error …

and also showing this pop up box in disk management when i connect my hard drive

pop up msg :

after i press ok , im getting this error msg…

also tried to update my passport but the update software is also telling me" USB is NOT FOUND"

so couldn’t upadate the firmware also

so can any one help me to solve my prblem

Yes I have plugged in the WD External hard drive to different places while connecting it to my laptop and still get the same result. I also tried using another USB cable from my brother’s WD External Hard drive that still works and it is still not being detected, not only that but now my computer freezes when it’s connected to it and I try to go to “My Computer” to look for the WD hard drive. I’ve tried the Mac again and it detects it, but when I go into it to move files to the Mac it tells me that “I don’t have the permission required on the files to be moved” (I’m paraphrasing here of course). So I’m still without my files in the WD hard drive!!! Any suggestions?  Well I’m starting to give up in trying to repair the WD hard drive, it seems they are just too crappy!! Does anybody have any suggestions on how I can at least retreive my data from it? Any sort of 3rd party programs that are good for this?

1 Like

i just took apart my external Hard drive. and just by looking at the board for the connections were cheaply put together. so soon my external will an internal. a mass majority of u that is having trouble with the connection problems and that its not recognizing ur drive. and u want ur data on ur external i would recommend taking it apart and do as i did and just save the main drive and put it as an internal drive…All it is, is a internal hard drive put into a crappy sodered together external connection drive…i for one is not buying another WD drive…psst…stick to calculators

How hard is it to get a replacment drive from WD qwithout a receipt. usually i dont keep reciepts with computer parts cause they are outdated within 12 months and you would asume they would last at least 12 months. my drive is the 750gb my passport. im not sure on its release date or how long there warranty is but you would asume 12 to 24 months they could back there products… anyone got a new one under warranty without a receipt

We bought three of these My Passport units as part of a disaster recovery archival rotation.  In theory, this was going to be a big improvement from backup tape rotation.  Less than three months in, one of the three started having the problem discussed in this thread.  That drive is toast, apparently.  

I once owned a WD MyBook external hard drive for my personal computer and it died the same sort of random death.  WD seems to just not be into that whole “quality” or “reliability” thing. 

I didn’t replace the MyBook with a WD product, and I’m leaning toward finding a different brand to replace these My Passports as they (inevitably) fail.

So what’s the solution to fix it?

I’ve had exactly the same problem. Plug it in, blinking light.

I’m using a Y-Cable, i’ve used it on 2 different computers as well.

I have virtually the same problem as everyone here.  I have a Passport Essential WDBAAA5000xxx that I bought approximately one month ago.  Up until a couple of days ago, it worked fine on my Windows 7 64-bit OS.  One day I am using it without difficulty. The next day is a complete nightmare.  Mine is password protected as I have installed the WD Smartware.  I have tried all of these suggestions without success.  I have uninstalled the software and re-installed it.  I have used two different USB cables with identical results.  I have upgraded the firmware and software on the drive [yes, I can perform these tasks].  The bottom line is that I cannot see the data on my drive.  The Smartware [?] reports that there is “NO WRITABLE WD SMARTWARE PARTITION FOUND”. And despite updating the software, it still nags me to install the latest software update. It would appear that something is wrong with either the firmware and/or the software.  It is also possible, I suppose, that Windows may be partly at fault.  However, that is a problem to be resolved between WD and MS if true, not for the customer to try and resolve.  Either way, WD needs to help us resolve this issue quickly.

Just curious… have any of you checked Disk Management to see if the drive shows up there?