WD External Hard drive not recognized in my computer

I had the same problem, drive was not being seen by both my desktop and laptop.  I got a new usb cable and that did the trick.  Only $10 on the wd website.

D

I’ve had a Western Digital Passport 320gb for about 2 years and have had intermittant connection problems:

  1. The first problem is well known and is common with external drives – not just WD Passport ones. The Passport drive  will often not draw enough power from a single USB port with the cable supplied by Western Digital. The solution is easy – get a USB “Y” cable or “booster” cable.  It has an extra USB plug at the end so you can draw more power from a second USB port.  I have a few “Y” cables at home and have always had to use one to power my WD Passport.  WD sells one in its store here:

http://store.westerndigital.com/store/wdus/en_US/DisplayAccesoryProductDetailsPage/ThemeID.1300400/productID.106596600/categoryID.13095900/parid.13092600/catid.13095900

But they come standard with most (but not all)  2.5" hard drive enclosures today, and you can get one for about $15-20 shipped from Newegg, Tiger Direct or Amazon.  So it’s a better deal as you get the enclosure too which can come in very handy to make an extra external drive out of an old laptop drive. If you go this route, buy a SATA enclosure instead of an IDE or ATA enclosure as most laptop drives today have SATA connections. However, if you know you have a spare IDE drive around that you want to utilitze, buy an enclosure with an IDE connection.

It would be nice if WD supplied the Y/booster cable as a standard accessory with all its Passport drives.

  1. The second problem I’ve had I think pertains mainly to the Passport and the model I have. The USB mini jack is a litle too large/loose, resulting in a loose connection with the USB cord that causes the drive to frequently disconnect  from my laptop while in use. Even a little movement will cause the disconnects. This has been highly annoying, and this past week almost resulted in a catastrophe.  What happened was it disconnected from my laptoip while I was transferring an 8gb folder. Windows immediately threw up error messages about read/write failures.  When I re-connected the Passport, Windows would recognize it but not fully and when I tried clicking on the drive in My Computer, I got an error message: “Error performing inpage operation.”   So I couldn’t browse the drive nor perform a chkdsk normally as the right-click menu was not showing up either.  A google search thankfully turned up the solution. I had to use a DOS command to run chkdsk on the Passport which fixed the drive.

But to avoid this issue in the future, I knew I had to put the drive in a new enclosure. Thankfully I had a spare SATA enclusure handy and so I put the Passport drive in there. Since doing that, the drive has been running like a champ. NO DISCONNECTS.  Zero.  What’s more, it seems to be more responsive in terms of transfer speed and browsing files on the drive.  I should have done this earlier as I knew about the problem for a few months.  I can only chalk this problem up to poor quality control.The mini USB port that WD put in this model of the Passport is of poor quality.

Be careful, as I have read that not all WD Passport drives can be extracted from their enclosures … that some of the newer models have the USB port permanently attached to the drive which prevents you from re-using the drive in a notebook and also from putting it in another external exclosure. But my Passport is R/N: B7B  and these can easily be taken out of the plastic enclosure that it comes with.  Look on the back label for the R/N number.  For instructions on how to take apart thismodel, do a search on YouTube for “Western Digital Passport disassembly” and look at the video by the person called “amerist” … his instructions are easy to follow.

If you want a recommendation of a HD enclosure, look at the Rosewill model RX81U-AT-25A at Newegg. This is what I have my WD Passport drive in now. It’s solid and runs smoothly. No Issues. And I feel better knowing that my data is better protected from dodgy USB connections.

Your data is too important to take chances. So if you have the B7B Passport model and are getting these constant disconnects, I highly recommend trying  this solution.  If you have another model proceed with caution, because as I said, not all Passport drives can be put in another enclosure.

–Pat

fzabkar wrote:
AIUI clicking is symptomatic of weak read heads or media damage. AFAICS, your drive requires professional data recovery. :frowning:

what should you do if it is clicking? does the warranty cover it or what…?

I have a WD3200ME-01 product and two PCs (a notebook and a desktop) both running WinXP SP3.

The HD is working fine when connected to the notebook. But if I try to connect it to the desktop, a new hardware is detected and the process to install the new usb device fails.

So, I can say the HD and USB cable are ok. The problem is a incompatibility between the HD and the desktop windows configuration.

The biggest difference between that system and an ordinary windows installation is the internal HD using two partitions, but I can’t believe this is the problem. That system is using C and E as Internal HD partitions and D as the optical device.

The USB ports are working fine and the windows is ok.

I will try to use the WD HD with other systems.

As weird as this may sound, my WD 1600 wouldnt show up on windows 7 (2 different machines). i jiggled the usb cord until i felt it start spinning. It installed and worked. This isnt the first time this has happened and I have some more Passports that have done the same thing. As soon as i get this stuff off, Im getting another drive.

I was experiencing the same problem. My unit (passport essential) worked once at the time of my original backup

and then never again. Each time I plugged it in on the same or alternate computer

I would consistency get a error message " USB device not recognized" with no apparent fix.

I was mad as heck. Finally, after pressing really hard on the cable input at the drive end

I was able to get my computer to recognize it. I know it sounds crazy, but I was

able to get it to work long enough to restore my files. This unit is a piece of ■■■■

and not up to WD standards. I will seek replacement.

You may like to compare how Microsoft’s UVCView utility sees the external drive on your two machines:
http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe

I believe it should be detected as a mass storage device.

i have the same problen how can i return this i bought this since last dec. untel now i can’t make it work i have 3 pc  and same error not recognized

I have run into this with several USB external drives of various make and models.   So far the answer works for all of them.

The problem seems to be one of power to the drive.  When I use a standard USB connection cable (USB mini to USB Standard) the computer indicates reacts in one of the following ways…

1.  it cycles through trying to connect then disconnecting.

or

  1.  it tells me that the proper driver cannot be found.

or

3.  it merely doesn’t recognize the USB device and gives no information.

However, when I have used a unique USB cable then it works with each of my external drives. (so far).

I have a USB cable that connects to the external drive with a USB Mini connector and to the computer with two (2) USB standard connectors.  One of the USB stand connectors is labeled ‘Data/Power’ and the other is labeled ‘Power’.

Once I use that cable then the computer recognizes the external drive, doesn’t need an additional driver and is ready to use.   This works with all 5 of my external drives and all six if my work stations.

Hope that helps!

Thanks,

G

I don’t know if you have solved your problem yet or not.  (I am still wading through the whole thread.)  I had a similar problem with my WD 500 GB portable drive too.  I found a great program that has allowed me to restore my data.  It is called Zero Assumption Recovery.  It costs about US$50 to purchase online and you have to have another driver to save the recovered data to, but it was very easy to use.  I used the “recover current data” and it found every single file… as far as I can tell.  (I had over 400GB of data.)  This was the best $50 I ever spent.  The scan does take a very long time (almost 20 hours) but part of that might have been the processor on my labtop!!  :-)  I hope this helps!!  Good Luck!!

External HD is 1 month Old…Fired it up a few times…now blink, blink, blink…what the shiessss!!!

Can you hear the drive spin up? Any vibration? Did you drop it? Did you overvolt it with the wrong adapter?

Can you see it in Disk Management? Device Manager?

Can you see the USB enclosure with Microsoft’s UVCView utility?
http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe

Today i had the same problem. I kept un, and reconnecting it on only one computer a few times. Then i tried pluging it in to different ports, which didnt work either. Finally i got out my Usb Hub and used that and guess what. It worked!!! Im not sure if this will work for you guys, But try it! I only used my computer, i didnt use anyone elses. Good Luck!:wink:

I’m betting that your hub was externally powered.

A standard USB port is current limited to 500mA. However a 2.5" drive typically requires around 800mA during startup and 400mA thereafter. Some USB ports are OK with this, while others are not.

You can get around this limitation with a Y-cable that picks up power from two USB ports.

1 Like

I read that WD told someone that their unit is defective, if that is so then every one posted on this board with the same problem have a defective unit with data is no longer accessible. To me this sounds really crazy! My unit worked for quite awhile then it stopped. My friend got his the same day from the same place and he has no problem. It seems to be that a patch or some type of driver should be available to handle this problem. I will be buying another one, by another company.

im having the same problem as well. When i connect it to my USB port it shows USB devise not recognised and one of the devices attached to the computer has malfunction and windows does not recognise it. I unplug and plugin again but still fail to do so. I bring it to the store and they change a new case and device for me but still the same… so whats the real prblem actually? i need the info inside…

hi, im having that problem with a WD 1 TB :-S … i connect it to my mac and it does not mount, after a while it says that it cannot read it and asked me to ignore it or initialize, when i click initialize i can see it on disk utility but i am not able to repair o do a diagnostic,… i did tried it on windows programs that you asked and it does appear there, would really appreciate any help… i would love to recover my files PLEASE HELP

I dropped by accident my hard drive wd passport and by then my computer doesn’t recognized the hd, I used the USB device driver and I see some data, what is going to be the next step? How I can interpret the data?, I heard a little noise.

          —===>Device Information<===—
English product name: "External HDD    "

ConnectionStatus:                  
Current Config Value:              0x01  -> Device Bus Speed: High
Device Address:                    0x01
Open Pipes:                           2

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x81  -> Direction: IN - EndpointID: 1
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x02  -> Direction: OUT - EndpointID: 2
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Device Descriptor<===
bLength:                           0x12
bDescriptorType:                   0x01
bcdUSB:                          0x0200
bDeviceClass:                      0x00  -> This is an Interface Class Defined Device
bDeviceSubClass:                   0x00
bDeviceProtocol:                   0x00
bMaxPacketSize0:                   0x40 = (64) Bytes
idVendor:                        0x1058 = Western Digital Technologies, Inc.
idProduct:                       0x0702
bcdDevice:                       0x0102
iManufacturer:                     0x01
     English (United States)  "Western Digital "
iProduct:                          0x02
     English (United States)  "External HDD    "
iSerialNumber:                     0x03
     English (United States)  “???”
bNumConfigurations:                0x01

          ===>Configuration Descriptor<===
bLength:                           0x09
bDescriptorType:                   0x02
wTotalLength:                    0x0020  -> Validated
bNumInterfaces:                    0x01
bConfigurationValue:               0x01
iConfiguration:                    0x00
bmAttributes:                      0xC0  -> Bus Powered
MaxPower:                          0x00 =   0 mA

          ===>Interface Descriptor<===
bLength:                           0x09
bDescriptorType:                   0x04
bInterfaceNumber:                  0x00
bAlternateSetting:                 0x00
bNumEndpoints:                     0x02
bInterfaceClass:                   0x08  -> This is a Mass Storage USB Device Interface Class
bInterfaceSubClass:                0x06
bInterfaceProtocol:                0x50
iInterface:                        0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x81  -> Direction: IN - EndpointID: 1
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x02  -> Direction: OUT - EndpointID: 2
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

I don’t know if this will help, but my passport (320gig, currently at 25%) would attatch to the pc, and computer would make the attatching sound, but it would not have the drive listed in the “my computer” folder. The icon that has the status info (%used, locked and temp at the corner of the screen) would say that it had 0% used, and the program WD smartware said no writable partition found. I tried to connect and reconnect several times, and no luck.

Finally i decided to give up on it and send the tech support an email. I waited till today (this all happened last night) and checked my email but the tech person was talking way out of my understanding, odd for a person who can usually get that kind of stuff, so i tried going oldschool fix and restarted my pc.

 I used the second user profile on my computer I created yesterday with the help of an apple person as a test to make my iPod function properly (control panel>users>create new-“test”-make sure it is an administrator). This user has only the basics so that may have helped the software sort through all the confusion. I attached the drive again and it still said the same but after waiting a few minutes and bringing up the WD smartware program it rescanned the drive itself and found the files. It asked if I wanted to scan and fix and I said yes. Now it is telling me that it may have been removed while copying files. I don’t believe this to be the case, but I could be wrong I suppose. I made sure to remove the drive after clicking the remove safely thing.

Anyway, i have went back to the other user, my original, (i have decided to keep “test”, aparently it is quite useful) and reattached the drive and it works fine now. with the one exception that the cord is still ultra sensitive and will disconnect easily when wiggled or sometimes i think even looked at to intently!

Hope this help all those who need it, and sorry to get your hopes up if not. I certainly dont want to be like the tech people who say “If the files are not important to you you can just reset it and it should work fine.” If the were not important, then why would i have bought an external hard drive to keep them?!

Hi-

I am having this exact same problem…I think it got unplugged while starting up now no computer will recognize it. The light comes on and I can hear it running, the WD window comes up but only lists the computer and does not recognize the drive at all. It sounds like this is the same issue as you…did you ever find a solution or recover your data? If so please respond. I am desperate to get my data back!