WD External Hard drive not recognized in my computer

I have read each and every thread/ post and it sounds like we all are having very simliar problems. I have tried  all but 1 solution with ZERO success. I like many of you bought the device as a back up storage only now to find that the device actually needs a back up of its own because it lacks reliability. Passport essential is less tan 6 months old and it worked up until last week. It is recognized in device manager and in the system under discs and under USB as external hard drive. In the disc manager it even has the name/model of the device…yet it still will not show up in my computer so I can not gain access to get my stuff!!!

Okay I am done-- I am signing up with carbonite

I have not tried the Y cable but I am so desperate I will go buy one tomorrow–why because I am desperate and need the stuff off the darn hard drive

Just been reading this thread and i’m also experiencing the same problems.  i only bought this hard drive last month and now it’s not working =(. iv’e checked on disk management and device manager and my hard drive doesn’t appear to be there it only says initio combo device default controller. when i plug it in it makes the plug and play noise but still doesn’t appear on my computer.  iv’e ran uvc and here are my results any help guys?

—===>Device Information<===—


Current Config Value:              0x01  -> Device Bus Speed: Full

Device Address:                    0x01

Open Pipes:                           0

*!*ERROR:  No open pipes!

          ===>Device Descriptor<===

bLength:                           0x12

bDescriptorType:                   0x01

bcdUSB:                          0x0200

bDeviceClass:                      0xFF  -> This is a Vendor Specific Device

bDeviceSubClass:                   0xFF

bDeviceProtocol:                   0xFF

bMaxPacketSize0:                   0x40 = (64) Bytes

idVendor:                        0x13FDidProduct:                       0x1618

bcdDevice:                       0x0100

iManufacturer:                     0x00

iProduct:                          0x00

iSerialNumber:                     0x00

bNumConfigurations:                0x01

          ===>Configuration Descriptor<===

bLength:                           0x09

bDescriptorType:                   0x02

wTotalLength:                    0x0012  -> Validated

bNumInterfaces:                    0x01

bConfigurationValue:               0x01

iConfiguration:                    0x00

bmAttributes:                      0xC0  -> Bus Powered

MaxPower:                          0x01 =   2 mA

          ===>Interface Descriptor<===

bLength:                           0x09

bDescriptorType:                   0x04

bInterfaceNumber:                  0x00

bAlternateSetting:                 0x00

bNumEndpoints:                     0x00

bInterfaceClass:                   0xFF  -> Vendor Specific Device

bInterfaceSubClass:                0xFF

*!*CAUTION:    This appears to be an invalid bInterfaceSubClass

bInterfaceProtocol:                0xFF

*!*WARNING:  must be set to PC_PROTOCOL_UNDEFINED 0 for this class

iInterface:                        0x00

*!*ERROR:  0xFF is the prerelease USB Video Class ID

—===>Device Information<===—
ConnectionStatus:                  Current Config Value:              0x01  -> Device Bus Speed: FullDevice Address:                    0x01Open Pipes:                           0*!*ERROR:  No open pipes!
          ===>Device Descriptor<===bLength:                           0x12bDescriptorType:                   0x01bcdUSB:                          0x0200bDeviceClass:                      0xFF  -> This is a Vendor Specific DevicebDeviceSubClass:                   0xFFbDeviceProtocol:                   0xFFbMaxPacketSize0:                   0x40 = (64) BytesidVendor:                        0x13FDidProduct:                       0x1618bcdDevice:                       0x0100iManufacturer:                     0x00iProduct:                          0x00iSerialNumber:                     0x00bNumConfigurations:                0x01
          ===>Configuration Descriptor<===bLength:                           0x09bDescriptorType:                   0x02wTotalLength:                    0x0012  -> ValidatedbNumInterfaces:                    0x01bConfigurationValue:               0x01iConfiguration:                    0x00bmAttributes:                      0xC0  -> Bus PoweredMaxPower:                          0x01 =   2 mA
          ===>Interface Descriptor<===bLength:                           0x09bDescriptorType:                   0x04bInterfaceNumber:                  0x00bAlternateSetting:                 0x00bNumEndpoints:                     0x00bInterfaceClass:                   0xFF  -> Vendor Specific DevicebInterfaceSubClass:                0xFF*!*CAUTION:    This appears to be an invalid bInterfaceSubClassbInterfaceProtocol:                0xFF*!*WARNING:  must be set to PC_PROTOCOL_UNDEFINED 0 for this classiInterface:                        0x00*!*ERROR:  0xFF is the prerelease USB Video Class ID

UVCView is detecting the Initio INIC-1618 “SATA to USB (MASK ROM) Bridge Controller IC” inside the enclosure. It is not detecting the WD hard drive behind the bridge chip.

If you don’t mind voiding your warranty, then you can remove the drive from the enclosure and attach it directly to a computer motherboard. Hopefully the bridge chip is on a separate bridge board, and not integrated into the hard drive.

Catman01, I would examine the partition table and boot sector with Microsoft’s Sector Inspector:

Extract the above archive to the one folder and execute the SIrun.bat file. The procedure will generate a report file named SIout.txt which you can then upload to a file sharing service.

databackplease, do you see your drive with UVCView? Device Manager? Disk Management?

I have a WD2500ME - never dropped or abused.  OS:  Windows XP

Plugged it into the USB port on the front of my desktop, like I have so many times before, but this time my computer wouldn’t recognize the drive.  USB device viewer did not see the drive either.  Tried several thumb drives and the viewer read them immediately. 

Plugged the drive into a port on the back of the CPU. . . . .the external harddrive works like a champ.   WEIRDNESS, but I’m a happy camper!  :smileyvery-happy:

Go to “My Computer”   right click the WD icon next to DVD or CD drive choose properties,choose “hardware”, choose WD-westerd digital etc.  and choose “repair”  or similar and foolow the instructions.Usually it works, not always.

It´s very poor fromWD to continue selling this type of HD without own drives inside.

Sometimes there may be a faulty USB -cable.Then you have to pull the plug connected to HD itsels to the right or left until your computer reacts.

I suggest a common demonstration march to WD Head Quarters till they makes better products.


Markku Kiiskinen

Similar problem for me. My WD disk has worked for months (perhaps years) and suddenly is not recognised. I have tried different USB ports, different PC’s, different cables and no joy. 

It doesn’t show up in My Computer but does spin with no noises and does light up. I just want to get the data off the disk now!!!

The UVCScan has the following error at the top

ERROR:  no String Descriptor for index 76

hmm, looks like I’ve just arrived at the party which apparantly never ends.

I have a WD passport SE 1TB, my laptop is HP with 64 bit Win 7, everything worked fine for almost half a year until yesterday.  I brought the WD to a friend’s, and transfered bunch of files to two other computers, 1 macbook pro, 1 win xp, everything went through, no problem.  but after I took my WD home, my own laptop won’t recognize it anymore.  my WD passport SE has smartware for security, it now still pumps the screen ask for password to unlock (the drive blinks and spins as usual), I typed in correctly, it says drive now unlocked, and then…nothing.  when everything worked perfectly, after unlocking the drive, I would find it under My Computer’s Hard Disk Drive section, but now after unlocking it only shows as CD-drive WD smartware, and I can’t do anything with it, can’t access my files and data.  I click on the CD-drive wd icon, it would seem the system starts scanning the device, but nothing will eventually come up, I think it actually soft crash the system.  when I unplugged it, a warning pops up says the device will have to be formatted, whatever…

I’ve tried:

  1. different 2.0 USB cables, no help.

  2. connecting to all available USB ports on my laptop, no help.

  3. wiggling the cord or whatever, no help.

  4. checking under disk manager, when connected and unlocked, the disk manager would soft crash…

  5. looking under device manager, shows it’s there, but “no driver installed”, and of course it’s supposed to be compatable with win 7 and should work with drive’s own stand-along installer the way it used to, but…

  6. installing the firmware updater, click and nothing happened…

so I took it to a WD authorized repair center early today, explained to them my problem.  the tech connected it to their system (XP), guess what? everything works all finey and dandy, they looked at me like I’m stupid, and I do feel very stupid.  but it still won’t freaking work on my own laptop.

so the good news is my WD is actually still good, I will have to try more other computers, but at the mean time, I can’t use it on my own laptop.

oh great, it’s working now, I haven’t got a clue of how or why…

after visiting the repair center, hooked up to my laptop, still same [deleted] different day, after I sort of just “let it be” for about 30 mins, out of a sudden, everything came together, it’s recognized, it’s in device manager, it’s in disk manager, I scanned through my files no problem, and I’m now running WD lifeguard diagnosis (which wasn’t possible).

I’m glad it’s working again, but god knows when it will decide not to? without knowing the problem, it feel like working with a ticking time bomb.

I am running Windows 7 home premium on a HP DV6 notebook. When I plug in the WD external HD via USB, the windows explorer does not  recognize the WD HD. I used  Paragon Partition Manager 10 to look at the issue. The computer recognizes the WD HD but there are no drive letters assigned to the partitions in the WD HD. After assigning drive letters, I can use the WD HD.

I am looking to find a permanent fix for this issue and will post it leter.

I can understand people’s frustration when something works and then stops working, but please take the time to check if you’ve done everything on your end to protect your investment.

first off, power is a lot more important than the obvious…

plugging it in/unplugging when not in use is a good practice however if you have a surge protector or battery backup (bbackup is best), plug it in there.

keep in mind of USB power surges…they DO happen. Make sure anything you are connecting is clean, not bent, dry etc.

surges large or small can and will destroy use of your drive…that isn’t a WD hardware fault.

I’ve seen other people post info about checking out device manager/disk management. Here is a good site for that rundown as well as some other useful info: http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=194531

When a HD goes, there isn’t too much you can do to get it working again…that’s why it is very important to try to have a proactive mindset…back up your backup.

If you have access to a desktop computer, you can always try taking apart the external enclosure. They usually have regular hard drives inside or laptop hard drives. If it is a regular (IDE, the wide grey ribbon cables) drive then you can just plug it into your motherboard on your desktop and try to get it to be recognized that way. It could be that the internal parts in the external drive are faulty. There are also adapters you can purchase (which are godsends btw) that will allow you to hook up to USB. Here is an example http://www.cooldrives.com/index.php/saandidehadr1.html

Believe it or not, but there is an old trick called a “cold boot” that sometimes works. If your drive is failing just about all tests and you can’t get it to do much of anything, this would be a last resort kind of thing. Basically, get an antistatic bag (put it inside a few ziplock bags too), put the drive in it (out of the enclosure that is) and throw it in the freezer over-night. When you take it out the next morning, you must be very quick; have everything ready to go. Just plug it in, boot up the computer and hope for the best. If this method actually works for you, you have a very limited amount of time to start backing up your data. You don’t have to leave it in over night either…but I would recommend at least and hour or two.

Google it if you don’t believe me…

If you have access to programs like The Ultimate Boot CD or Knoppix, I would suggest using them to boot to and transfer your files…there is too much to explain on those if you are unfamiliar with them, but again, Google works wonders.

As for the filesystems on these hard drives…i’m not 100% positive on this, just assuming…BUT…I would assume that they are formated in FAT32 format considering that is universally read throughout windows operating systems. The NTFS format is different becase it allows for encryption on your disks…which is the standard from Windows XP and up. There isn’t really anything that will make it incompatible with your “new” computer in terms of hardware or the formatting considering everything that is out there in terms of pc’s and their operating systems…to suggest that would be kind of silly don’t you think?

Anywho, I hope that some of this info helped some of you out there or at least gave you a better insight as to what you can and cannot do…

Oh and I almost forgot! Data recovery software for those who want to try it. I’ve always had good luck with Stellar Phoenix and Digital Rescue Premium.

Best of luck to you all


Running windows XP and nada…this stinks!

I’m betting all of these new computers are having the same problem I am.  Windows 7 isn’t recognizing the Western Digital software.  I’ve tried 6 cords,  two different Western Digital external hard drives and NONE are recognized…  on my NEW computer, but when I pulled out an old one using XP it was all there. I spent the night transferring things OFF the Western Digitals until they can find a fix for the new software. I imagine it’s a Microsoft mess up, but they won’t acknowledge it so it will be up to WD to make their units compatible.

got the same problem with my terabyte WD using firewire. lights up from  its own power source. Occasionally is recognized and can scan files inside the WD. But then it just disappears. I can sometimes get it to go by turning on off reconnecting and rebooting, but then it jus disappears. Any ideas?

Hey! Where can I find such a repair centre in Holland? I have a WD My Book Pro with the same problem. I have thousands of photo’s on it, only partly backuped on disks. For a year or so I didn’t have any problems. Than the misery begun: my computer (with Vista) did not recognize My Book now and than. It worked to pull out the cables and restart the computer. Recently it stopted recognizing it at all. If I had only read this and other sites with complaints about WD My Book before, I would have made a backup right away, when it still worked.

I think WD should  warn people for this misery in the manual and on their site. A ‘sorry’ afterwards in the forum doesn’t help people.

I have the same problem as everyone else, and i thought my files were gone forever.  All you have to do is go here, http://www.ehow.com/how_4474341_recover-data-external-hard-drive.html i promise it works with no viruses, and download the pc inspector and follow the directions on the ehow. If u have problems you can email me at terriblyartistic@yahoo.com. I wish someone had done this for me, so thats why im doing it for you. Theres no reason to have to pay someone to recover all your files for you.

=} i really hope this helps

him having the same problem as well. i’ve just brought mine today uploaded some stuff to it and now it wont let me back into it. it keeps saying i need to format it but i’ve formated it like 10 times and it wont do anything


Who do you thank and what for? Obviously you succeeded in getting the WD back on your computer? How?

Until now I only succeeded in getting an icon on my toolbar, which, when I open it, the computer recognizes as “WD 3 Externa USB Device”. But I don’t have any contact and I cannot find this device elsewhere on my computer.