WD External Hard drive not recognized in my computer


#1

Hi gud day!

It’s been a month that my external hard drive could not be detected in my laptop. the light still lights up when i connect it via USB cable but nothing appears on the computer. I also tried connecting it to different computers and cable and it is still not recognized… I also check it on disk management and it is still not visible. is my hard drive damaged? is there a chance I could retrieve all my files?


#2

you must bent your usb cable when connect it to pc


#3

Hi there, were you able to find a solution ? I have a similar problem with my WD-160GB External Hard Drive. Gosh I need all the data in there ? Dont tell me its gone !


#4

1.  is the drive spinning without clicking noise?  If no, check cable on both external drive and computer.  Is the USB port good with another drive?

2.  if yes, do you see the disk under device manager/windows and system profiler/mac? If no, reboot or unplug-replug.

3.  if yes, do you see the partition under disk Management/winows and Disk Utility/Mac? If no, check if security enabled?

  1. if yes, do you see the drive letter assigned/desk management/windows?  If no, right click and assign drive letter.

5. if yes, you may have to format the drive again.   **** Do this after all other methods failed as it will wipe out your data.***


#5

Hi, Having the same problems. Could u tell me how  to format, if the computer doesnt recognise the external hard drive ?.   This seems to be quite a popular problem as u search google for an answer. My drive was recognised for about 5 mins this morning but then automatically decided it wasnt recognised anymore then dissapeared. Hope this all makes sense. 

Any help appreciated.


#6

penry1,

What is your drive from below?

http://support.wdc.com/product/download.asp?level1=1&lang=en

1.  Pick the drive and see if there is Firmware update.

2.  if yes, please update to latest.

3.  if no, go to Disk Management/Windows and Disk Utility for Mac

4.  If the drive volume shows up right click and format to NTFS/Windows and GUID partition and HFS+J for Mac


#7

Hi there I have exactly the same prob as you. Mine is a WD-160GB Hard drive…Could u please let me know if u recovered ur data ? Please help


#8

Excuse my langue, but this is [text deleted]  ridiculous, so many people are having this problem I can see over a thousand people have view this post alone… and there is yet to be a fix for it by you people. I’m really quite fed up with this product and I’m going to return it and buy another brand. You’ve lost a customer, and gained bad word of mouth, nice job! Wiping something your trying to save shouldn’t be an option, thanks.


#9

are you all having the same issue as me?  When I plug it in, the activity light keeps blinking.  I tried a few different cables and that doesnt solve the prob.

Some have said online that there might be a virus on the drive.  Do any of you see that as possible for causing it to be unrecognized?


#10

I just got off the phone with support…mine would not recognize as well and the support guy says that it is defective.  Pisses me off.  I now have to pay a data recovery company to get my data.

Do any of you have any suggestions for reasonable pricing for data recovery?


#11

Can you hear the drive spinning?

If not, is it buzzing or beeping as if trying to spin up?

Did you drop the enclosure?

Did you overvolt it with the wrong AC adapter?

If you are using Windows, can you see the enclosure with Microsoft’s UVCView utility?

http://www.users.on.net/~fzabkar/USB_IDs/UVCView.x86.exe


#12

Hi I am able to hear spinning sound .When i use Microsoft’s UVCView utility it is giving failed Enumeration and below

error

   —===>Device Information<===—

ConnectionStatus:                  FailedEnumeration
Current Config Value:              0x00  -> Device Bus Speed: Low
Device Address:                    0x00
Open Pipes:                           0
*!*ERROR:  No open pipes!

          ===>Device Descriptor<===
*!*ERROR:  bLength of 0 incorrect, should be 18
bLength:                           0x00
bDescriptorType:                   0x00
bcdUSB:                          0x0000
bDeviceClass:                      0x00
*!*ERROR:  Device enumeration failure

Please suggest as i am not able to use new 500 gb passport essential even for once.

Whenever i try to run it it is installing device driver and after that it says unknown device.


#13

ISTM that the drive is DOA. A warranty replacement is the only practical option. :frowning:

To see what the UVCView report should look like, try another mass storage device, eg flash drive.


#14

Hi,

I am having the same problem as so many others my friend. It appears the product is defective - the problem I have found is solved if you pick up the harddrive (wait for it) and hold is vertical or move the USB cable a little so the drive is recognised. Whichever way you look at it, from a business point of view this product is not up to WD normal standards. I suggest a product recall and replacement once you have re-engineered the USB connection issue.

Cheers


#15

Hi, I had same problem with my 320GB and I went to ADD HARDWARE in the CONTROL PANEL and ran a scan, it didn’t find it, but I said yes to IS HARDWARD CONNECTED, then clicked next… next again, then it could see it but it had DISABLED it… agreed to ENABLE device and my computer can see it now… so goto your control panel in MY COMPUTER and see if it sees it…


#16

This post is referring to the MyPassport Protable Hard Drive.

BEFORE REDING THIS, please keep in mind that I am no expert and that this is based on personal observation and speculation based on my own expirements using this product and five different computers as well as my understanding of company explantions from WD and Microsoft. I may be wrong, and if I am, please send an E-mail my way via [text deleted for privacy] explaining my error. If I am right or this works for you, please feel free to send me an E-mail so that I may know.

I have had the same problem. However, are you all running Windows 7? If so, your upgrade has been WD’s loss. With the way the external hard drives work, from my understanding, does not allow it to be compatable with Window 7s new and more effecient file format. These hard drives do some come with a driver of thier own as a design descision, which was fine and dandy before Windows 7 popped up, as all PCs ran a similar default driver system. Now, with Windows 7s new driver and file format system (which is still able to sommunicate with all other pre-Windows 7 product I own that can with its own driver), WD’s hard drives do not follow a format that Windows 7 can read.

Think of it as XP and older (as I am not sure about Vista’s file system) using British Pounds. Well, the new Windows 7 uses Euros, but will still accept pounds. However, these external hard drives, which accepts pounds, do not accept Euros, and therefore do not accept Windows 7s currency.

Because of this, I am getting a new external hard drive that will speak to my two Windows 7 computers, but will keeps this has a back-up driver for my three XP-based computers. This product works well with XP in my expierence, but just doesn’t have the capabilities to work well with Windows 7.

Like I said before, please keep in mind that I could be wrong and am no expert. Thank you for reading and I hope this helps you.


#17

I had this problem too and was really upset.  But I did “Alt + Ctrl + Delete” and went to “TASK MANAGER” and then clicked the tab “Processes” and then clicked the tab labled Image Name to catagorize them by name and found “WDSmartWare.exe” in the list and clicked on it once to highlight it and clicked end process.  After I did that I unplugged my WD  Passport Essential and plugged it back in and it came back on and was recognized and all my files were still there.  I hope this helps.  I use Windows XP.   p.s  I don’t know if that is the safest  thing to do but it worked for me.


#18

I’m having the same problem.

I’m using XP version 5.3, so in my case the problem has nothing to do with compatibility issues with Windows 7.

My drive does work intermittently.  Sometimes when I first plug it in I can read my files, but then it disconnects.  Usually it will go through a cycle of connecting then disconnecting before deciding on disconnection.  I’ll get an array of messages ballooning up in my system tray, and sometimes I’m even treated to the install new software wizard.  Throughout all of this it’s little white light shines on.  Its all very entertaining.

So, what are we supposed to do? I’ve had my hard drive just over one year, its worked hard for the full length of its warranty so it is probably ready to accept this is its last dance, and so am I.  As a westerner I like the idea of a shiny new hard disk.  I couldn’t really give a **bleep** that this type of thing is an incredibly wasteful use of humanity’s finite resources or that farce of this flavour is occuring on a massive scale.   What I would like to know is how can I rescue my music? (Thank the lord I haven’t paid for music since my Maxtor HD died with all my real music collection). 

Perhaps its just time to admit all this technology is really a bit **bleep** and go back to tapes.

:wink:


#19

 When I plug it in, the activity light keeps blinking.  I tried a few different cables and that doesnt solve the prob.keeps on giving a click sound when trying to read

  Do any of you see that as possible for causing it to be unrecognized?


#20

AIUI clicking is symptomatic of weak read heads or media damage. AFAICS, your drive requires professional data recovery. :frowning: