WD external drive not recognized on macbook


My macbook doesn’t recognize the WD drive. It’s been working for last two years, somehow it stopped working from last week. I can see the light turning on when I plugged in, but didn’t show up in the desktop or disk utility. I tried ‘diskutil list’ on the terminal, but it doesn’t show up in the list. I’ve connected to another mac but it didn’t recognized either. :frowning:

Please help me out how I can access the files. Thank you!!


Is the drive showing under disk utilities?

Are you able to test with a different USB cable?

No, the drive is not showing under the disk utilities and I just tried a new cable and it looks like it’s connected for the first 10 seconds but suddenly got ejected by itself…I shut down the macbook several times and reinstall the WD drive utilities but still have no luck. I can see the light on, really don’t know what to do…

Having the same problem/same time frame. Wondering if it might have to do with a recent OS update?

Today I tried with another mac and it worked. Seems like it has to do with OS security update.

Thanks all for your replies!

1 Like