WD EX4 login timeout issue with new SW Update

Just started to login to my EX4 today (9/9/2020, at 11am approx), looks like there was an update recently.

When I login it requires me to accept the terms and conditions and asks me to set the admin password, but this was done years ago.

Then it asks to enable auto update, also done years ago, and to participate in program for improving this S/W and H/W.

After that when logged in, looks like all my settings have been removed.

When I try to setup all over again, it continuously gives me message of " * Login timed out. Please login again.", That is it does NOT give me any time to make any changes.

I have tried using different apps to login, Safari, Firefox and Chrome, still the same thing. It is set as static IP.

Does WD actually test any of their software, or is this a hit and miss scenario. WD get your act together, I use this for business and cannot loose any more time.

I intend to raise a complaint with the appropriate authorities, as this is costing me time, money and business opportunities.

Get this fixed ASAP WD.



Do you know what is the latest firmware installed on your device? It seems like some one might have reset your device manually or something.

Firmware Version 2.12.127 (01/08/2019) release from WD was 1 year and 7 months ago.

Hi jebusx,
I can’t login with enough time to get anything done. Even check the software, and when I do the software block is blank?

The version must be later than that, this was never the login procedure. Nobody in my home knows what the WD EX4 is and what it is used for. So NO one actually touched it.

A few days earlier
9before all this occurred) I did restart, by removing the power chord and restarting it. I logged in without any trouble at all, at the time. It often freezes and does not allow anyone to login, that is the login prompt is never presented, so I need to remove power to get it up and running again.

In regards to the version, there MUST have been an update as I previously mentioned there is a new procedure for login. It still allows me to select the static IP (in Safari, which I set earlier) and login that way, and there is an agreement that must be accepted at the beginning of the login procedure (this is new), this was never the login previously.

I believe this occurred in a previous software version a few years back.

By the way I have always had auto update enabled.



By the way, the pervious issue I mentioned that saw on this website is as follows:



Solution is to restart the WD EX 4 by removing the power chord and counting to 10 and then reconnecting.



I know this is an old thread, but someone may like to know the following: I did not find that a power failure as suggested above corrected the problem. On the other hand I found a work around.

When you get the “Login timed out. Please login again.” message, if you will ignore the message and go to the browser address bar and reconnect to the device you will find you are logged in. It made be breathe a little easier when I accidentally discovered this fact.

1 Like

2021 and still working as a fix, thanks for sharing.

My OS3 EX4100 is having this exact problem. I tried the soft reset, 10 minute power boot, ect. nothing seems to work. I’ll unplug it for longer and see if that helps but I have consistently not been able to access the Dashboard for a while. I have access to my files to consume but the dashboard is key right now and it stinks I can’t figure out a fix.