WD EX4 IP Address Disconnected

Upgraded to the latest firmware via web deshboard. After it restarted and came back up it has the IP address as disconnected on the display. Unable to browse to the dashboard or access the shares via explorer. I can still ping the device and the WD network tool finds it and shows the static IP etc that is set.

From the scan tool:
Device Type: Network Device
Manufacturer: Western Digital Corporation
Model: WDMyCloudEX4
Model Number: LT4A
Description: WD My Cloud 4-Bay Network Storage
Device Home Page:
Vendor Name: Western Digital Corporation
Status: Healthy

Have you tried pressing the reset switch located on the back of the unit? It should clear basic system errors and cycle the unit’s IP address. If the issue persists then you may have to send an E-mail to WD Support about this.


Thanks for the reply @Trancer
We have a winner.

I did try the reset as well as removing the power completely as I found it would not shut down, was just restarting. So anyway after a few full power re-cycle and resets it has restarted with an IP address. Yeh for me as I was not looking forward to a second WD NAS crash where I lost everything.

Thanks for the quick reply.
I had tried a reset and a full power cycle with no luck, derided after your
reply I should try again but still no luck. In discust I pulled the power
and yeh, we have a new IP and we can access.