WD Ethernet Link 2 Disconnected

We have a new DX4000 and we keep getting the following error.

WD Ethernet Link 2 Disconnected

Ethernet port 2 is disconnected (after previously having two ports simultaneously connected).

How can we reset it so it doesn’t think we’ve plugged two cables in at once?

We had two cables in during testing, but we will likely only use a single ethernet port when we deploy it.

We can “ignore” the alert, but it will still show up in the alert viewer.  We want the device to forget that there were ever two cables plugged in at once.

I’ve already tried removing the two network adapters from the TEAM and then reconfiguring the IP settings for a single, unteamed, port.

SOLUTION:

Edit the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Western Digital\Sentinel\EthernetLinkMonitorProvder\NetRedundancyActive

Change from 1 to 0.

I’ve also tried disabling the second network port.  Didn’t change anything.

I’ve ignored the alert, but it doesn’t stay ignored, and it triggers emails.

We absolutely cannot have this thing triggering emails all the time for no reason.

WD Ethernet Link 2 Disconnected
BACKUP 1/20/2012 9:11 AM
Ethernet port 2 is disconnected (after previously having two ports simultaneously connected).
If one ethernet link is connected:

   1. Connect ethernet cable to disconnected link port.
   2. Connect this cable to switch on same network as connected link.

or if neither ethernet link is connected:

   Use Windows Network Troubleshooting at Control Panel -> All Control Panel Items -> Troubleshooting ->Network and Internet

I’ve found

C:\Program Files\Western Digital\Western Digital Ethernet Link Monitor\ .

There’s an XML file in here, but it’s pretty much incomprehensible.

The installer seems to be at C:\Windows\Installer\13aa87.msi .

There’s a bunch of registry entries, too…

And just as I’m typing this, what do we have here?

HKEY_LOCAL_MACHINE\SOFTWARE\Western Digital\Sentinel\EthernetLinkMonitorProvder

NetRedundancyActive  REG_DWORD 0x00000001

Gonna change that bad boy to 0!

This seems to have fixed it.