WD Esstnial USB3 3 TB worked out of box. Firnware upgrade - only one visible at a time


I just got my two identitcal brand new WD Essential 3 TB USB 3.0 drives 2 hours ago. They worked fine together on my Patriot USB 3 expansion card. Then I think to myself before putting anyting on them to update the firmware so as not to lose some data if I decide to do so further on.

Using windows 7 ultimate 64.


Now I can only access one of the drives (only one is visible) at a time. Both drives work fine separately (after a reboot) but I cannot use both simultaneously and no not even on two separate USB 2.0 ports.

What gives? Is there a way to revert to an older firmware?

Many thanks in advance,

Tha Other Guy 1234


Read the thread in the link below.


It has nothing to do with the firmware it is the way Windows 7 works.

You only need to do the changes to one drive. It only takes a few minutes and you will have both working at the same time.



Works fine now! I love you man! You saved saved me from a nervous breakdown :slight_smile:

Best Wishes!