WD Essentials Drive not Recognized on Win 7

Just formatted my PC and reinstalled Windows 7 Ultimate.  So far so good on everything,

except, my WD Essential 1TB Drive is not detected on USB 3.0

It doesn’t show in BIOS, My Computer, WD Smartware, etc. Not at all. Worked fine prior to formatting/installing.

Have tried installing SES Drivers. No help.

Have .net 3.5, didn’t work, installed .Net 4.0, still nothing.

Any ideas?

Did you check and see if all the USB drivers and controlers are up to date? Is USB 3 enabled? Does the drive work with USB 2.0?


It’s working on one of my USB 2.0 ports, but not other 2.0 ports or my 3.0

Yes 3.0 is enabled.  Not sure how to update drivers for the other drives so it’s recogized in all. Still would prefer it to be on the 3.0, but 2.0 is okay for now…

Updated my Mobo drivers but that didn’t help…

Since it it works on some USB ports but others it may be an update issue. Go into the Device Manager find the USB controller and start updating the drivers there and see if that helps. At least it will eliminate that. Is the USB 3.0 an addon or did it come with the PC? If it’s an addon check the maker’s site for updated software.


1 Like


I’m having something similar to your problem. I have 2TB MyBook Essential USB 3.0 and motherboard GIGABYTE GA-990XA-UD3. When my Win7 64-bit starts It doesn’t detect anything at my USB 3.0 port. If I unplug either power cable or usb cable and then plug it back then It gets detected at USB 3.0 port. When I boot WIn7 with MyBook plugged at any USB 2.0 port then It gets detected by Windows normally. I have tried:

Update MyBook firmware

Update BIOS

Update Etron USB 3.0 drivers

Nothing helped!!!

Got the update through AsRock (Motherboard manufacturer).  I suggest anyone with the same problem looks for All Drivers relative to their motherboard rather than just the motherboard drivers.  They’re just slightly hidden, but once downloaded worked fine!

1 Like

Thanks for posting back with what worked.