WD Essential SE; SES Driver error

Hi I’ve a WD Essential SE 1 TB and since a couple of weeks I’ve some trouble installing/using this drive.

When I plug in the USB cable into my USB Port windows is telling me it’s installing new hardware.

after a while I see an error with “driver not found” (- red cross).

Even after downloading the right SES Driver from the WD site the yellow explanation mark is gone (in device manager). So I assume the WD Essential is correctly installed, but I still can’t find this drive in “my computer”. After restarting my PC, windows is detecting new hardware and automatically will install the WD Essential but still gives a error with the SES Driver. So in some kind of way the driver is uninstalled after a quick reset. This happened everytime when I tried to connect the WD Essential to my PC.

I tried it plenty of times with different SES Driver downloads without any succes.

I know one of you can help me with this! :smiley:

Thanks in advance!


Just for testing purposes please try it on another computer to verify if you have the same issue.


same error… 


It seems that this is an issue with the hard drive itself. Just to be sure please try to run a test using Western Digital’s Data Lifeguard Diagnostics

will try this tonight… will keep you updated…

I only see my SATA drives on Data Lifeguard Diagnostics… not the wd one… :frowning: