WD EP doesn't react

Yesterday i felt asleep watching a movie on my WD Elements Play. After i decided to watch it in the morning, i tried to run the harddrive by using the remote.

There was no reaction on the TV.

The blue light is lightening, but it feels like it is off.

It’s not the problem of the batteries in the remote and plug in & out is also not the solution. After plugging it back in the harddrive is stil running without any reaction on the TV.

What’s wrong? I didn’t do anything. The WDEP is just standing there and doesn’t work after a second.

Please help me…

still no connection and no signal.

blue light is still on and it’s definetly working.

connecting the WDEP to my Mac let me see that the files on the harddrive are okay.

after plugging out the usb-connection the WDEP goes off and i can put them back on power with the remote. -> NO SIGNAL!

Exact same issue, I can see the files on my laptop but theres no signal when connected to the TV. Checked all the cables and batteies nothing…Please help!!!

I have having exactly the same problem. I have seen the movie last night and when I turned on this morning…it’s nothing comes in the TV. I plugged in the drive with my Laptop and I found the drive and also found that the movies are there, but again I try to connect the drive with the TV with HDMI but nothing is coming in the TV but the Blue light is still ON.

Please give me support as I’m stacked in this situation.

Ich habe leider das selbe problem .Auf dem Rechner kann ich alles sehen und hören und

auf dem TV totenstille.Wer kann mir helfen?

Hallo Arupbhai hast du denn schon eine antwort auf dein Problem bekommen.

Das würde mir sicher auch weiter helfen.Meine Enkeltochter hat einen Film geschaut,

nach dem essen wolte ich sie wieder anschalten und da war nichts mehr zusehen.

Ich weiss mir keine erklährung.

first of all

this is the english forum. i’m from germany, but not everybody.

it seems like a problem of western digital.

i contacted the support. my guarantee is not extended, so i’m going to send it in.

Just a thought, but has anybody tried to connect using the composite cable (red, white, yellow)? It could be that the EP has switched the settings somehow.

Yes, I have tried but no luck. WD replied that if the power cycling and reset button doesn’t bring it back then the device is defective and it needs to be replaced…!!! it’'s VERY VERY Strenge!!